games-fps/gzdoom: Bump to version 4.1.3
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>
Sun, 9 Jun 2019 06:56:10 +0000 (15:56 +0900)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 10 Jun 2019 19:50:54 +0000 (21:50 +0200)
The openal flag is default on since end users typically expect audio
support by default. Adds patch to allow FluidSynth 2 builds.

Closes: https://bugs.gentoo.org/687692
Closes: https://bugs.gentoo.org/687716
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12228
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
games-fps/gzdoom/Manifest
games-fps/gzdoom/files/gzdoom-4.1.3-fluidsynth2.patch [new file with mode: 0644]
games-fps/gzdoom/gzdoom-4.1.3.ebuild [new file with mode: 0644]

index c452275367512341178103419a5ee6e2a410c072..afab53dec94b6f97ad7de9ca680363d867cd84fb 100644 (file)
@@ -1 +1,2 @@
 DIST gzdoom-4.1.2.tar.gz 13045742 BLAKE2B 38c70eb82ba266e5b41bf62f28f4cee77ba17c0cc1e4186bf11be9021386511346c111874b695ef56a4ed3c93668bb64a71ba4169183646e49d0ab60a1c0793a SHA512 915029e676b17dd330aeee17fa8a9e07bb8e7a16e8ebce9fcdcd24e5b2f0cc48fd8f6914314029b332112ad4215a0f0d45d8e448e9025ac3c2a708a5e0bbd399
+DIST gzdoom-4.1.3.tar.gz 13084313 BLAKE2B d082efacc99264eff92f51dac1a4ff742ee00c65fec769cd143e1ffa7a1527060735efc7325a5fd5d0950bdce52cf28941837c1a32e3e88483ece574de1fba64 SHA512 16d3db1320eaaf39477971e3724228850abe216fa792d79e288f3551ab635344c22699c10ccf9e7da4dc49543e1b5ff8be7f0053b79dc53e274e33cc17a667ac
diff --git a/games-fps/gzdoom/files/gzdoom-4.1.3-fluidsynth2.patch b/games-fps/gzdoom/files/gzdoom-4.1.3-fluidsynth2.patch
new file mode 100644 (file)
index 0000000..1ae12a8
--- /dev/null
@@ -0,0 +1,28 @@
+From: Jan Engelhardt <jengelh@inai.de>
+Date: 2018-10-16 14:29:56.900427855 +0200
+
+Make the build work with fluidsynth 2.x.
+
+---
+ src/sound/mididevices/music_fluidsynth_mididevice.cpp |    5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+Index: gzdoom-3.6.0/src/sound/mididevices/music_fluidsynth_mididevice.cpp
+===================================================================
+--- gzdoom-3.6.0.orig/src/sound/mididevices/music_fluidsynth_mididevice.cpp
++++ gzdoom-3.6.0/src/sound/mididevices/music_fluidsynth_mididevice.cpp
+@@ -78,10 +78,13 @@ extern "C" unsigned __stdcall GetSystemD
+ #define FLUID_CHORUS_DEFAULT_LEVEL 2.0f
+ #define FLUID_CHORUS_DEFAULT_SPEED 0.3f
+ #define FLUID_CHORUS_DEFAULT_DEPTH 8.0f
+-#define FLUID_CHORUS_DEFAULT_TYPE FLUID_CHORUS_MOD_SINE
+ #endif
++#ifndef FLUID_CHORUS_DEFAULT_TYPE
++#define FLUID_CHORUS_DEFAULT_TYPE FLUID_CHORUS_MOD_SINE
++#endif
++
+ // TYPES -------------------------------------------------------------------
+ // EXTERNAL FUNCTION PROTOTYPES --------------------------------------------
diff --git a/games-fps/gzdoom/gzdoom-4.1.3.ebuild b/games-fps/gzdoom/gzdoom-4.1.3.ebuild
new file mode 100644 (file)
index 0000000..8a614dd
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop xdg
+
+DESCRIPTION="A modder-friendly OpenGL source port based on the DOOM engine"
+HOMEPAGE="https://zdoom.org"
+SRC_URI="https://github.com/coelckers/${PN}/archive/g${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BZIP2 DUMB-0.9.3 GPL-3 LGPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fluidsynth gtk gtk2 +openal openmp"
+
+DEPEND="
+       media-libs/libsdl2[opengl]
+       sys-libs/zlib
+       virtual/jpeg:0
+       gtk? (
+               gtk2? ( x11-libs/gtk+:2 )
+               !gtk2? ( x11-libs/gtk+:3 )
+       )"
+RDEPEND="
+       ${DEPEND}
+       fluidsynth? ( media-sound/fluidsynth )
+       openal? (
+               media-libs/libsndfile
+               media-libs/openal
+               media-sound/mpg123
+       )"
+
+S="${WORKDIR}/${PN}-g${PV}"
+PATCHES="${FILESDIR}/${P}-fluidsynth2.patch"
+
+src_prepare() {
+       rm -rf docs/licenses || die
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DINSTALL_DOCS_PATH="${EPREFIX}/usr/share/doc/${PF}"
+               -DINSTALL_PK3_PATH="${EPREFIX}/usr/share/doom"
+               -DDYN_FLUIDSYNTH=OFF
+               -DDYN_OPENAL=OFF
+               -DDYN_SNDFILE=OFF
+               -DDYN_MPG123=OFF
+               -DNO_GTK="$(usex !gtk)"
+               -DNO_OPENAL="$(usex !openal)"
+               -DNO_OPENMP="$(usex !openmp)"
+       )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       newicon src/posix/zdoom.xpm "${PN}.xpm"
+       make_desktop_entry "${PN}" "GZDoom" "${PN}" "Game;ActionGame"
+       cmake-utils_src_install
+}