dev-python/line_profiler: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 20:53:37 +0000 (21:53 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 20:53:37 +0000 (21:53 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/line_profiler/Manifest
dev-python/line_profiler/line_profiler-2.0.ebuild [deleted file]
dev-python/line_profiler/line_profiler-2.1.2.ebuild [deleted file]

index 26d2eb4d4966eedd5de4283633291908342ba1b2..af93c64fe4d6babeaef9a7bc56b0b393d87883c4 100644 (file)
@@ -1,3 +1 @@
-DIST line_profiler-2.0.tar.gz 68478 BLAKE2B fb814b251e8f18a51e65297e57523b85c55b4060444c42d99801aa88c8ee0279abf14def6ecd5a9b09550e46e2d27b3ec809b1333725b00de64b58f117c76ed7 SHA512 c0335fc69fb47c150fa5555af4f7fdf4b172ca12ee6512e04ba854c4a81f3e6ee5594e484d11c8ea7e9e8048e3f3b8661db52332d4ac645195a0e050acea4ecb
-DIST line_profiler-2.1.2.tar.gz 83131 BLAKE2B 0f61d7dbab24988a50c1c0a9dce528cf792ca53b5f4c60f00fd9dabfd3d3e109f2d245867bc1ebb8294fb84343907e3593c416341ea1b0d7ae626cda8a3218d3 SHA512 625a585915d338fe8ef2f37c5b5bc024f769a623380b85725bcf33686e4cc62a211c2e91552e093dee940367b0d2ad306c5cbe7f1e8f1574eb731d128b8e22bd
 DIST line_profiler-3.0.2.tar.gz 45185 BLAKE2B 04e617cc7b6c9686192281ab1cdfdef2cfc6ce3c7aa6b9962ed2369620618af8835b93bafe89f8d1288b45d4120d71f728ec577d5c5d035699c2d7a49d6be7c1 SHA512 9a5d1821c02fc063081854ba98a17eca21af65d5aecf4ce32c67806d31bf0c936291a30409845ce6f94211cdaaaf0859ab5e2b437e1a086fd4f60fc2a0fd2742
diff --git a/dev-python/line_profiler/line_profiler-2.0.ebuild b/dev-python/line_profiler/line_profiler-2.0.ebuild
deleted file mode 100644 (file)
index b3890bb..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Line-by-line profiler"
-HOMEPAGE="
-       https://github.com/rkern/line_profiler
-       https://pypi.org/project/line_profiler/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-       "
-
-python_test() {
-       "${EPYTHON}" -m unittest discover -v "${S}"/tests/ \
-               || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/line_profiler/line_profiler-2.1.2.ebuild b/dev-python/line_profiler/line_profiler-2.1.2.ebuild
deleted file mode 100644 (file)
index 1111379..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Line-by-line profiler"
-HOMEPAGE="
-       https://github.com/rkern/line_profiler
-       https://pypi.org/project/line_profiler/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/ipython[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-python_test() {
-       "${EPYTHON}" -m unittest discover -v "${S}"/tests/ \
-               || die "Tests failed with ${EPYTHON}"
-}