dev-python/pycdio: Use append-cflags
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:34:25 +0000 (18:34 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:53:41 +0000 (18:53 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pycdio/pycdio-0.20-r1.ebuild

index d7094c248fd0788bf315c28495669b33add075d4..5d6a6d47586fdea6c71097c556484316b78a5af5 100644 (file)
@@ -3,9 +3,10 @@
 # $Id$
 
 EAPI=5
+
 PYTHON_COMPAT=( python2_7 )
 
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
 
 DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
 HOMEPAGE="http://savannah.gnu.org/projects/libcdio/ https://pypi.python.org/pypi/pycdio"
@@ -21,11 +22,10 @@ DEPEND="${RDEPEND}
        dev-lang/swig
        dev-python/setuptools[${PYTHON_USEDEP}]"
 
-CFLAGS="${CFLAGS} -fno-strict-aliasing"
-
 RESTRICT="test"  # currently tests fail
 
 python_prepare_all() {
+       append-cflags -fno-strict-aliasing
        # Remove obsolete sys.path and adjust 'data' paths in examples.
        sed -i \
                -e "s:^sys.path.insert.*::" \