app-admin/newsyslog: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 3 Apr 2017 22:04:22 +0000 (00:04 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 3 Apr 2017 22:04:36 +0000 (00:04 +0200)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-admin/newsyslog/newsyslog-1.1-r1.ebuild [new file with mode: 0644]

diff --git a/app-admin/newsyslog/newsyslog-1.1-r1.ebuild b/app-admin/newsyslog/newsyslog-1.1-r1.ebuild
new file mode 100644 (file)
index 0000000..5f5290e
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+#inherit eutils
+
+DESCRIPTION="a highly configurable program for managing and archiving log files"
+HOMEPAGE="http://www.weird.com/~woods/projects/newsyslog.html"
+SRC_URI="ftp://ftp.weird.com/pub/local/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="sys-apps/groff"
+
+RDEPEND="
+       virtual/cron
+       app-arch/gzip"
+
+PATCHES=( "${FILESDIR}"/newsyslog-html.patch )
+
+DOCS=( newsyslog.conf AUTHORS ChangeLog INSTALL NEWS ToDo )
+
+src_configure() {
+       local myconf="--with-syslogd_pid=/var/run/syslog.pid"
+
+       has_version 'app-admin/syslog-ng' \
+           && myconf="--with-syslogd_pid=/var/run/syslog-ng.pid"
+
+       econf \
+           --with-gzip \
+           --with-newsyslog_conf=/etc/newsyslog.conf \
+           ${myconf}
+}
+
+src_install() {
+       emake \
+               DESTDIR="${D}" \
+               catmandir="${T}"/dont-install \
+               install
+       einstalldocs
+}