dev-libs/expat: Remove vulnerable
authorSebastian Pipping <sping@gentoo.org>
Sat, 26 Oct 2019 10:43:19 +0000 (12:43 +0200)
committerSebastian Pipping <sping@gentoo.org>
Sat, 26 Oct 2019 10:44:11 +0000 (12:44 +0200)
Bug: https://bugs.gentoo.org/694362
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.68, Repoman-2.3.16

dev-libs/expat/Manifest
dev-libs/expat/expat-2.2.6.ebuild [deleted file]
dev-libs/expat/expat-2.2.7.ebuild [deleted file]

index eaacc0fdd283c37f5b8d6aef33c8f020acccffce..60480d79ac53609600a0117495468d1cead846a3 100644 (file)
@@ -1,3 +1 @@
-DIST expat-2.2.6.tar.bz2 513322 BLAKE2B 386736da1f2204fa8f15ee4d1b3d11f01ed691efe6951b9f24f2bd30ab5494e75da6a97ceb1ffe4a0a8ecdc80f96f51d21c54f35a2cbc352a9fe9425545bf15b SHA512 dbfb635a5fe7b190722664263a0dd437b512fdf519bc53bd4905567f4bfb4b1e89a021562da63df8cacd48b706d1dea60ccde47f279e57400ad3c846b6e9c4e6
-DIST expat-2.2.7.tar.xz 424264 BLAKE2B acf2fa5cf374a671603f4a12b81239ba3b1634bab66d736e87fb516ce52d599711b3014218bef822640781b8852c7238b6f071b5bd439a13838fcbc7767d06a7 SHA512 bf3af5b5a8e1a1b76658a41f67dbe7b10104e3b724e1882f529fecc509b07c75dde02d8f8b89b1522e05484e8dc417d47651c5f8d4aac1749676ba5c4752c107
 DIST expat-2.2.8.tar.xz 422324 BLAKE2B 1f3e8bbce7f05aa080ca647d12a4ff9bf6d21cd31366d70daabcf8db48985e0b644faac5e251e0a559a74f0a27b247ede64b6f117940a5f7f70dc1cce0f0036a SHA512 102a3af89af37a961f81ade2dfb4f3e13bf779110decff9f1462f21079aa6959009871c39b933d9bf47ebc3ee50d3f8d5b41859dce833d290f17886a2aa80aa9
diff --git a/dev-libs/expat/expat-2.2.6.ebuild b/dev-libs/expat/expat-2.2.6.ebuild
deleted file mode 100644 (file)
index a8ea133..0000000
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-AUTOTOOLS_AUTO_DEPEND=no
-inherit autotools eutils libtool multilib toolchain-funcs multilib-minimal usr-ldscript
-
-DESCRIPTION="Stream-oriented XML parser library"
-HOMEPAGE="https://libexpat.github.io/"
-SRC_URI="https://github.com/libexpat/libexpat/releases/download/R_${PV//\./_}/expat-${PV}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="elibc_FreeBSD examples static-libs unicode"
-DEPEND="unicode? ( ${AUTOTOOLS_DEPEND} )"
-RDEPEND=""
-
-DOCS=( README.md )
-
-src_prepare() {
-       default
-
-       # fix interpreter to be a recent/good shell
-       sed -i -e "1s:/bin/sh:${BASH}:" conftools/get-version.sh || die
-       if use unicode; then
-               cp -R "${S}" "${S}"w || die
-               pushd "${S}"w >/dev/null
-               find -name Makefile.am \
-                       -exec sed \
-                       -e 's,libexpat\.la,libexpatw.la,' \
-                       -e 's,libexpat_la,libexpatw_la,' \
-                       -i {} + || die
-               eautoreconf
-               popd >/dev/null
-       fi
-}
-
-multilib_src_configure() {
-       local myconf="$(use_enable static-libs static) --without-docbook"
-
-       mkdir -p "${BUILD_DIR}"w || die
-
-       if use unicode; then
-               pushd "${BUILD_DIR}"w >/dev/null
-               CPPFLAGS="${CPPFLAGS} -DXML_UNICODE" ECONF_SOURCE="${S}"w econf ${myconf}
-               popd >/dev/null
-       fi
-
-       ECONF_SOURCE="${S}" econf ${myconf}
-}
-
-multilib_src_compile() {
-       emake
-
-       if use unicode; then
-               pushd "${BUILD_DIR}"w >/dev/null
-               emake -C lib
-               popd >/dev/null
-       fi
-}
-
-multilib_src_install() {
-       emake install DESTDIR="${D}"
-
-       if use unicode; then
-               pushd "${BUILD_DIR}"w >/dev/null
-               emake -C lib install DESTDIR="${D}"
-               popd >/dev/null
-
-               pushd "${ED}"/usr/$(get_libdir)/pkgconfig >/dev/null
-               cp expat.pc expatw.pc
-               sed -i -e '/^Libs/s:-lexpat:&w:' expatw.pc || die
-               popd >/dev/null
-       fi
-
-       if multilib_is_native_abi ; then
-               # libgeom in /lib and ifconfig in /sbin require libexpat on FreeBSD since
-               # we stripped the libbsdxml copy starting from freebsd-lib-8.2-r1
-               use elibc_FreeBSD && gen_usr_ldscript -a expat
-       fi
-}
-
-multilib_src_install_all() {
-       einstalldocs
-
-       # Note: Use of HTML_DOCS would add unwanted "doc" subfolder
-       docinto html
-       dodoc doc/*.{css,html,png}
-
-       if use examples; then
-               insinto /usr/share/doc/${PF}/examples
-               doins examples/*.c
-       fi
-
-       prune_libtool_files
-}
diff --git a/dev-libs/expat/expat-2.2.7.ebuild b/dev-libs/expat/expat-2.2.7.ebuild
deleted file mode 100644 (file)
index c7c1788..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-AUTOTOOLS_AUTO_DEPEND=no
-inherit autotools eutils libtool multilib toolchain-funcs multilib-minimal usr-ldscript
-
-DESCRIPTION="Stream-oriented XML parser library"
-HOMEPAGE="https://libexpat.github.io/"
-SRC_URI="https://github.com/libexpat/libexpat/releases/download/R_${PV//\./_}/expat-${PV}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="elibc_FreeBSD examples static-libs unicode"
-BDEPEND="unicode? ( ${AUTOTOOLS_DEPEND} )"
-
-DOCS=( README.md )
-
-src_prepare() {
-       default
-
-       # fix interpreter to be a recent/good shell
-       sed -i -e "1s:/bin/sh:${BASH}:" conftools/get-version.sh || die
-       if use unicode; then
-               cp -R "${S}" "${S}"w || die
-               pushd "${S}"w >/dev/null
-               find -name Makefile.am \
-                       -exec sed \
-                       -e 's,libexpat\.la,libexpatw.la,' \
-                       -e 's,libexpat_la,libexpatw_la,' \
-                       -i {} + || die
-               eautoreconf
-               popd >/dev/null
-       fi
-}
-
-multilib_src_configure() {
-       local myconf="$(use_enable static-libs static) --without-docbook"
-
-       mkdir -p "${BUILD_DIR}"w || die
-
-       if use unicode; then
-               pushd "${BUILD_DIR}"w >/dev/null
-               CPPFLAGS="${CPPFLAGS} -DXML_UNICODE" ECONF_SOURCE="${S}"w econf ${myconf}
-               popd >/dev/null
-       fi
-
-       ECONF_SOURCE="${S}" econf ${myconf}
-}
-
-multilib_src_compile() {
-       emake
-
-       if use unicode; then
-               pushd "${BUILD_DIR}"w >/dev/null
-               emake -C lib
-               popd >/dev/null
-       fi
-}
-
-multilib_src_install() {
-       emake install DESTDIR="${D}"
-
-       if use unicode; then
-               pushd "${BUILD_DIR}"w >/dev/null
-               emake -C lib install DESTDIR="${D}"
-               popd >/dev/null
-
-               pushd "${ED}"/usr/$(get_libdir)/pkgconfig >/dev/null
-               cp expat.pc expatw.pc
-               sed -i -e '/^Libs/s:-lexpat:&w:' expatw.pc || die
-               popd >/dev/null
-       fi
-
-       if multilib_is_native_abi ; then
-               # libgeom in /lib and ifconfig in /sbin require libexpat on FreeBSD since
-               # we stripped the libbsdxml copy starting from freebsd-lib-8.2-r1
-               use elibc_FreeBSD && gen_usr_ldscript -a expat
-       fi
-}
-
-multilib_src_install_all() {
-       einstalldocs
-
-       # Note: Use of HTML_DOCS would add unwanted "doc" subfolder
-       docinto html
-       dodoc doc/*.{css,html,png}
-
-       if use examples; then
-               insinto /usr/share/doc/${PF}/examples
-               doins examples/*.c
-       fi
-
-       find "${D}" -name '*.la' -type f -delete || die
-}