dev-python/python-caja: Readd and Bump to 1.24.0
authorAdam Feldman <NP-Hardass@gentoo.org>
Wed, 25 Mar 2020 22:38:20 +0000 (18:38 -0400)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 17:48:58 +0000 (13:48 -0400)
Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
dev-python/python-caja/Manifest [new file with mode: 0644]
dev-python/python-caja/metadata.xml [new file with mode: 0644]
dev-python/python-caja/python-caja-1.24.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-caja/Manifest b/dev-python/python-caja/Manifest
new file mode 100644 (file)
index 0000000..7f7de41
--- /dev/null
@@ -0,0 +1 @@
+DIST python-caja-1.24.0.tar.xz 312340 BLAKE2B a860cb1cc983221710d93943ac39b9b77761997fa6a52b32dceeeec381ee86d976c56266013d0370a28e7cb26de3601fec42234b4f91c78e5ac54992035e17ee SHA512 9febf7cae1736e30c80218dcfd3cc05b948823b99945ed67c1839ab5149aa3fe05b090d46c598810f0cde8ba66b83426c4642f6ebdbef6067f6b2fbc0798e816
diff --git a/dev-python/python-caja/metadata.xml b/dev-python/python-caja/metadata.xml
new file mode 100644 (file)
index 0000000..2d0b288
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>mate@gentoo.org</email>
+               <name>Gentoo MATE Desktop</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">mate-desktop/python-caja</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-caja/python-caja-1.24.0.ebuild b/dev-python/python-caja/python-caja-1.24.0.ebuild
new file mode 100644 (file)
index 0000000..6c6833c
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Python bindings for the Caja file manager"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+COMMON_DEPEND="${PYTHON_DEPS}
+       >=dev-libs/glib-2.50:2
+       $( python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]' )
+       >=mate-base/caja-1.17.1[introspection]
+       >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+       dev-util/gtk-doc
+       dev-util/gtk-doc-am
+       >=sys-devel/gettext-0.19.8:*
+       virtual/pkgconfig:*
+       doc? ( app-text/docbook-xml-dtd:4.1.2 )
+"
+
+src_install() {
+       mate_src_install
+
+       # Keep the directory for systemwide extensions.
+       keepdir /usr/share/caja-python/extensions/
+
+       # The HTML documentation generation is broken and commented out by upstream.
+       #
+       #if use doc ; then
+       #       insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+       #       doins -r docs/html/*
+       #fi
+}