dev-python/pytest-rerunfailures: Add missing mock py2-test-dep
authorMichał Górny <mgorny@gentoo.org>
Wed, 29 Apr 2020 10:54:06 +0000 (12:54 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 29 Apr 2020 11:02:57 +0000 (13:02 +0200)
Closes: https://bugs.gentoo.org/719996
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-rerunfailures/pytest-rerunfailures-8.0.ebuild

index e93e988df3798fbc6e1937713a156d5c5d606dde..a1904fda3eee322593fea95abee7779f5f07e26b 100644 (file)
@@ -18,6 +18,9 @@ IUSE=""
 
 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/pytest-4.4[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}"
+BDEPEND="
+       test? (
+               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+       )"
 
 distutils_enable_tests pytest