dev-python/urllib3: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 19:52:42 +0000 (21:52 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 19:52:42 +0000 (21:52 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/urllib3/urllib3-1.25.9.ebuild

index 9b3269254dc0ddb8bcae6e2eb44820f6e914d012..3b908729ee89e457eb174fb1044580e6b0be7e30 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
 PYTHON_REQ_USE="ssl(+)"
 
 inherit distutils-r1
@@ -31,7 +31,6 @@ RDEPEND="
        brotli? ( dev-python/brotlipy[${PYTHON_USEDEP}] )
 "
 BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                $(python_gen_cond_dep "
                        ${RDEPEND}
@@ -40,7 +39,7 @@ BDEPEND="
                        dev-python/pytest[\${PYTHON_USEDEP}]
                        >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
                        >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
-               " 'python3*')
+               " python3_{6,7,8})
        )
 "
 
@@ -70,6 +69,9 @@ python_test() {
                        ewarn "of circular dependencies for Python 2 removal.  Please test"
                        ewarn "manually in a virtualenv."
                        ;;
+               python3.9)
+                       einfo "Tests not yet ported to py3.9"
+                       ;;
                python3*)
                        pytest -vv || die "Tests fail with ${EPYTHON}"
                        ;;