old
authorMike Frysinger <vapier@gentoo.org>
Fri, 13 Apr 2007 10:44:27 +0000 (10:44 +0000)
committerMike Frysinger <vapier@gentoo.org>
Fri, 13 Apr 2007 10:44:27 +0000 (10:44 +0000)
sys-fs/quota/files/digest-quota-3.14 [deleted file]
sys-fs/quota/quota-3.14.ebuild [deleted file]

diff --git a/sys-fs/quota/files/digest-quota-3.14 b/sys-fs/quota/files/digest-quota-3.14
deleted file mode 100644 (file)
index e24c9b3..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e6ae17d4bf26012e820c3582ec7af487 quota-3.14.tar.gz 249016
-RMD160 2282bb8b14d6e61beea0841cac5a67eec9f3d85d quota-3.14.tar.gz 249016
-SHA256 e4226a5dc77303d417905658210ce861e1eb904bc2c7acd401c3a1373715942d quota-3.14.tar.gz 249016
diff --git a/sys-fs/quota/quota-3.14.ebuild b/sys-fs/quota/quota-3.14.ebuild
deleted file mode 100644 (file)
index cbe1fbc..0000000
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.14.ebuild,v 1.1 2007/03/25 12:09:39 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="Linux quota tools"
-HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
-SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
-IUSE="nls tcpd ldap rpc"
-
-RDEPEND="ldap? ( net-nds/openldap )
-       tcpd? ( sys-apps/tcp-wrappers )
-       rpc? ( net-nds/portmap )"
-DEPEND="${RDEPEND}
-       nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/quota-tools
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-
-       epatch "${FILESDIR}"/${PN}-3.13-configure-LANG.patch #131432
-       epatch "${FILESDIR}"/${PN}-3.14-headers.patch
-
-       # patch to prevent quotactl.2 manpage from being installed
-       # that page is provided by man-pages instead
-       epatch "${FILESDIR}"/${PN}-no-quotactl-manpage.patch
-
-       # Don't strip binaries (from Fedora)
-       epatch "${FILESDIR}"/quota-3.06-no-stripping.patch
-
-       sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
-}
-
-src_compile() {
-       econf \
-               $(use_enable nls) \
-               $(use_enable ldap ldapmail) \
-               $(use_enable rpc) \
-               $(use_enable rpc rpcsetquota) \
-               || die
-       emake || die
-}
-
-src_install() {
-       dodir /{sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,3,8}}
-       emake ROOTDIR="${D}" install || die
-       rm -r "${D}"/usr/include #70938
-
-       insinto /etc
-       insopts -m0644
-       doins warnquota.conf quotatab
-
-       dodoc doc/*
-       dodoc README.*
-       dodoc Changelog
-
-       newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
-       newinitd "${FILESDIR}"/quota.rc6 quota
-       newconfd "${FILESDIR}"/quota.confd quota
-
-       if use ldap ; then
-               insinto /etc/openldap/schema
-               insopts -m0644
-               doins ldap-scripts/quota.schema
-
-               exeinto /usr/share/quota/ldap-scripts
-               doexe ldap-scripts/*.pl
-               doexe ldap-scripts/edquota_editor
-       fi
-}