dev-libs/libpreludedb: Bump version 3.1.0
authorThomas Andrejak <thomas.andrejak@gmail.com>
Sun, 27 Nov 2016 22:36:02 +0000 (23:36 +0100)
committerGöktürk Yüksek <gokturk@gentoo.org>
Tue, 6 Dec 2016 17:27:10 +0000 (12:27 -0500)
dev-libs/libpreludedb/Manifest
dev-libs/libpreludedb/libpreludedb-3.1.0.ebuild [new file with mode: 0644]

index 904124439aea7ade373f4b69820878d6ddb5bfb9..2dd4bb3c6e7ed2db75278a116454f480374c7fa5 100644 (file)
@@ -1 +1,2 @@
 DIST libpreludedb-3.0.0.tar.gz 1269937 SHA256 608afa449388b2fcc25dc6aa2ad74ab2f22fd03ca3a0c0cdb2588d794f82d3ca SHA512 9d80e01be8cf028b8a843e68e45eeb84c561ff37e688fe5b8156e717f337b1db4d3de983f37a0544bf018238bec07580dce0c7208df005113efbba0aab34b981 WHIRLPOOL 1c700c34d05c5ba42fae40ff2597bf3f951bb49674eebfbb6ce80824bd59880f5a1402d786f00e4a5560da94c515968c11f9d84e67e88b1eedbfa02e364abd35
+DIST libpreludedb-3.1.0.tar.gz 1291186 SHA256 3ac2adade778941249fc87adcaebf39ef3acf17844632f690c66fb50dd48d857 SHA512 dcb98eff2521979c2956bdd6f3b661c346c0f6748ef820a75d77c948e426a996de26c7fc6b6c2abddc93277db3820eb2f44b61c87feb86483e720cf9b0e0124c WHIRLPOOL 85d0a79be0cd0f638368317ebb0020a60670a6fb1093868accfe3755bcf04988d2263775959732a32ae5b33e0169e95d215dc4af547780fc3bc1c0ad5054c3f0
diff --git a/dev-libs/libpreludedb/libpreludedb-3.1.0.ebuild b/dev-libs/libpreludedb/libpreludedb-3.1.0.ebuild
new file mode 100644 (file)
index 0000000..2e1ea1a
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Framework to easy access to the Prelude database"
+HOMEPAGE="https://www.prelude-siem.org"
+SRC_URI="https://www.prelude-siem.org/pkg/src/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc python mysql postgres sqlite"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="dev-libs/libgcrypt:0=
+       net-libs/gnutls:=
+       ~dev-libs/libprelude-${PV}
+       python? ( ${PYTHON_DEPS} )
+       mysql? ( virtual/libmysqlclient )
+       postgres? ( dev-db/postgresql:* )
+       sqlite? ( dev-db/sqlite:3 )"
+
+DEPEND="${RDEPEND}
+       doc? ( dev-util/gtk-doc )
+       sys-devel/flex
+       virtual/yacc
+       >=dev-lang/swig-3.0.7
+       virtual/pkgconfig"
+
+src_prepare() {
+       default
+
+       eautoreconf
+}
+
+src_configure() {
+       local python2_configure=--without-python2
+       local python3_configure=--without-python3
+
+       chk_python() {
+               if [[ ${EPYTHON} == python2* ]]; then
+                       python2_configure=--with-python2
+               elif [[ ${EPYTHON} == python3* ]]; then
+                       python3_configure=--with-python3
+               fi
+       }
+
+       if use python; then
+               python_foreach_impl chk_python
+       fi
+
+       econf \
+               --enable-easy-bindings \
+               --with-swig \
+               $(use_enable doc gtk-doc) \
+               ${python2_configure} \
+               ${python3_configure} \
+               $(use_with mysql) \
+               $(use_with postgres postgresql) \
+               $(use_with sqlite sqlite3)
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}