sci-libs/xgks-pmel: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 17:40:39 +0000 (18:40 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 17:40:39 +0000 (18:40 +0100)
Closes: https://bugs.gentoo.org/455906
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
sci-libs/xgks-pmel/files/aclocal.patch
sci-libs/xgks-pmel/xgks-pmel-2.5.5.ebuild

index 48d44d7476479926a18564ba06887fde9f520c26..dbedb2e49f293e02473680d3a8c8062f8667f485 100644 (file)
@@ -1,5 +1,5 @@
---- port/aclocal.m4.orig       2009-04-26 13:33:51.434402251 -0700
-+++ port/aclocal.m4    2009-04-26 13:43:33.466651210 -0700
+--- a/port/aclocal.m4
++++ b/port/aclocal.m4
 @@ -582,26 +582,6 @@
  ])])
  
  # Check for udres(3) library.
  #
  define([UC_LIB_UDRES], [dnl
---- port/configure.in.orig     2009-04-26 13:34:08.430308009 -0700
-+++ port/configure.in  2009-04-26 13:44:26.218430537 -0700
+--- a/port/configure.in
++++ b/port/configure.in
 @@ -24,8 +24,6 @@
  UC_PROG_FORTC
  UC_PROG_NEQN
  UC_PROG_INSTALL
  
  UC_UDPOSIX
---- port/master.mk.in.orig     2009-04-26 13:34:18.848400960 -0700
-+++ port/master.mk.in  2009-04-26 13:45:03.187651071 -0700
+--- a/port/master.mk.in
++++ b/port/master.mk.in
 @@ -19,8 +19,6 @@
  INSTALL_DATA  = @INSTALL_DATA@
  INSTALL_PROGRAM       = @INSTALL_PROGRAM@
index a329866fa00322351c75ca71114d8ce95cb45891..cc8aa0b44b78fc5e077f263212a002322551fe54 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-inherit eutils fortran-2 toolchain-funcs multilib
+inherit fortran-2 toolchain-funcs
 
 DESCRIPTION="PMEL fork of XGKS, an X11-based version of the ANSI Graphical Kernel System"
 HOMEPAGE="http://www.gentoogeek.org/viewvc/Linux/xgks-pmel/"
@@ -14,15 +14,13 @@ SLOT="0"
 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
 IUSE="doc"
 
-RDEPEND="
-       x11-libs/libX11"
-DEPEND="${RDEPEND}
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="
        sys-devel/flex
        sys-apps/groff"
 
-src_prepare() {
-       epatch "${FILESDIR}"/aclocal.patch
-}
+PATCHES=( "${FILESDIR}"/aclocal.patch )
 
 src_configure() {
        sed -i -e "s:lib64:$(get_libdir):g" port/master.mk.in \
@@ -40,28 +38,27 @@ src_compile() {
 
        # Fails parallel build, bug #295724
        emake -j1
-
-       cd src/fortran
-       emake -j1
+       emake -C src/fortran -j1
 }
 
 src_install() {
-       cd "${S}"/progs
-
-       for tool in {defcolors,font,mi,pline,pmark}; do
+       pushd progs >/dev/null || die
+       local tool
+       for tool in defcolors font mi pline pmark; do
                newbin ${tool} xgks-${tool}
        done
+       popd >/dev/null || die
 
-       cd "${S}"
        dolib.a src/lib/libxgks.a
 
-       dodoc COPYRIGHT HISTORY INSTALL README
+       dodoc COPYRIGHT HISTORY README
        doman doc/{xgks.3,xgks_synop.3}
        if use doc; then
                newdoc doc/binding/cbinding.me cbinding
                newdoc doc/userdoc/userdoc.me userdoc
-               insinto /usr/share/doc/${P}/examples
-               doins progs/{hanoi.c,star.c}
+
+               docinto examples
+               dodoc progs/{hanoi.c,star.f}
        fi
 
        insinto /usr/include/xgks