Bug #307707 - Fix fetch() to use the correct spawn function when calling
authorZac Medico <zmedico@gentoo.org>
Thu, 4 Mar 2010 06:57:52 +0000 (06:57 -0000)
committerZac Medico <zmedico@gentoo.org>
Thu, 4 Mar 2010 06:57:52 +0000 (06:57 -0000)
nofetch.

svn path=/main/trunk/; revision=15743

pym/portage/package/ebuild/fetch.py

index b89856e6e9a905044c39fe057222870188301651..353a4e678a0a0be9530c2b5c0686076729e2235f 100644 (file)
@@ -20,6 +20,7 @@ import tempfile
 import portage
 portage.proxy.lazyimport.lazyimport(globals(),
        'portage.package.ebuild.config:check_config_instance,config',
+       'portage.package.ebuild.doebuild:spawn@doebuild_spawn',
 )
 
 from portage import doebuild_environment, OrderedDict, os, prepare_build_dirs, selinux, _encodings, _shell_quote, _unicode_encode
@@ -1096,7 +1097,7 @@ def fetch(myuris, mysettings, listonly=0, fetchonly=0, locks_in_subdir=".locks",
                                        ebuild_phase = mysettings.get("EBUILD_PHASE")
                                        try:
                                                mysettings["EBUILD_PHASE"] = "nofetch"
-                                               spawn(_shell_quote(EBUILD_SH_BINARY) + \
+                                               doebuild_spawn(_shell_quote(EBUILD_SH_BINARY) + \
                                                        " nofetch", mysettings, fd_pipes=fd_pipes)
                                        finally:
                                                if ebuild_phase is None: