media-gfx/imagemagick: bump to v6.9.11-9 & v7.0.10-9
authorThomas Deutschmann <whissi@gentoo.org>
Sat, 9 May 2020 16:06:24 +0000 (18:06 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 9 May 2020 16:06:24 +0000 (18:06 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
media-gfx/imagemagick/Manifest
media-gfx/imagemagick/imagemagick-6.9.11.9.ebuild [new file with mode: 0644]
media-gfx/imagemagick/imagemagick-7.0.10.9.ebuild [new file with mode: 0644]

index 31340b4b30202ca5ce648ef3b42982f27dd9f4c2..500da892d38595a728b5bf6a184b4c711a4f94ee 100644 (file)
@@ -1,2 +1,4 @@
 DIST ImageMagick-6.9.11-7.tar.xz 9075300 BLAKE2B 669c9c4212afd7a8b6c336378b248607991156807522e0c53920bf846f87168deeba12e282a60e977d1056a32eb06302d8b2422d4982060e88048ae79ae8ad3a SHA512 7eb169679846ae18cc16fbf66d3e5903f4ad38373a4e24c1219fab7a5fe323afd60bd1c540c75931c069116ea8367a89d25c68283276dbfeda67cc4d601b2888
+DIST ImageMagick-6.9.11-9.tar.xz 9069640 BLAKE2B ab39f4723e4bc843a504ce29a840d24a0497d00ebaaf8a10589813d7bf13f5ef3774e9989dd38d667e1a9ad3dbc5357ca4a53533b5ef338781409c0b3bdde01a SHA512 8f8e6cdbbc4ff367304d29d3098dc208ac17e8037e31426e5e24d918ab13a292660e2944cb830fa814f297b69f8b2d693ac33b94f5ee4b8406cf52605ee00586
 DIST ImageMagick-7.0.10-7.tar.xz 9685636 BLAKE2B 20dd94a034038d420906779e78c35c3c7c73370ee7ee29833f63833e8923fb52416a4e4f1a5700795b6722c29dc3b060a3dc1708e267815e86e9e9756200e074 SHA512 020adb329bcc50af52e590b33edc2caf5c0f7b15eacaabd18e5dc9b755314b8238c0b869420662b2b70c406453cf125ed10d2cf0ac94d309c05dfcd7e5820b26
+DIST ImageMagick-7.0.10-9.tar.xz 9681168 BLAKE2B 0a26df054f6799dcc0cc576dc3d3e30689d3311ce658b220f4575d6ddf31063e8e9b1de57d5065171480dad5ae4f3a0bdde0d5ef7a5a7cdd267f2e76a210f30c SHA512 db19b39c41e3401ce454016a14c83d1188d38d7e4a31848c29344bd86ef14d4250208bcfb4b9e519f7d2d193a61724d980ce39e9d6e2388c872281e9383e2f54
diff --git a/media-gfx/imagemagick/imagemagick-6.9.11.9.ebuild b/media-gfx/imagemagick/imagemagick-6.9.11.9.ebuild
new file mode 100644 (file)
index 0000000..02b0c96
--- /dev/null
@@ -0,0 +1,255 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eapi7-ver eutils flag-o-matic libtool perl-functions toolchain-funcs multilib
+
+MY_PV="$(ver_rs 3 '-')"
+MY_P="ImageMagick-${MY_PV}"
+
+DESCRIPTION="A collection of tools and libraries for many image formats"
+HOMEPAGE="https://www.imagemagick.org/"
+SRC_URI="mirror://imagemagick/${MY_P}.tar.xz"
+
+LICENSE="imagemagick"
+SLOT="0/6.9.11"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 corefonts +cxx djvu fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp wmf X xml zlib"
+
+REQUIRED_USE="corefonts? ( truetype )
+       test? ( corefonts )"
+
+RESTRICT="perl? ( userpriv )
+       !test? ( test )"
+
+RDEPEND="
+       dev-libs/libltdl:0
+       bzip2? ( app-arch/bzip2 )
+       corefonts? ( media-fonts/corefonts )
+       djvu? ( app-text/djvu )
+       fftw? ( sci-libs/fftw:3.0 )
+       fontconfig? ( media-libs/fontconfig )
+       fpx? ( >=media-libs/libfpx-1.3.0-r1 )
+       graphviz? ( media-gfx/graphviz )
+       heif? ( media-libs/libheif:= )
+       jbig? ( >=media-libs/jbigkit-2:= )
+       jpeg? ( virtual/jpeg:0 )
+       jpeg2k? ( >=media-libs/openjpeg-2.1.0:2 )
+       lcms? ( media-libs/lcms:2= )
+       lqr? ( media-libs/liblqr )
+       opencl? ( virtual/opencl )
+       openexr? ( media-libs/openexr:0= )
+       pango? ( x11-libs/pango )
+       perl? ( >=dev-lang/perl-5.8.8:0= )
+       png? ( media-libs/libpng:0= )
+       postscript? ( app-text/ghostscript-gpl )
+       raw? ( media-libs/libraw:= )
+       svg? (
+               gnome-base/librsvg
+               media-gfx/potrace
+               )
+       tiff? ( media-libs/tiff:0= )
+       truetype? (
+               media-fonts/urw-fonts
+               >=media-libs/freetype-2
+               )
+       webp? ( media-libs/libwebp:0= )
+       wmf? ( media-libs/libwmf )
+       X? (
+               x11-libs/libICE
+               x11-libs/libSM
+               x11-libs/libXext
+               x11-libs/libXt
+               )
+       xml? ( dev-libs/libxml2:= )
+       lzma? ( app-arch/xz-utils )
+       zlib? ( sys-libs/zlib:= )"
+DEPEND="${RDEPEND}
+       !media-gfx/graphicsmagick[imagemagick]
+       virtual/pkgconfig
+       X? ( x11-base/xorg-proto )"
+
+S="${WORKDIR}/${MY_P}"
+#S="${WORKDIR}/ImageMagick6-${MY_PV}"
+
+src_prepare() {
+       default
+
+       # Apply hardening #664236
+       cp "${FILESDIR}"/policy-hardening.snippet "${S}" || die
+       sed -i -e '/^<policymap>$/ {
+                       r policy-hardening.snippet
+                       d
+               }' \
+               config/policy.xml || \
+               die "Failed to apply hardening of policy.xml"
+       einfo "policy.xml hardened"
+
+       elibtoolize # for Darwin modules
+
+       # For testsuite, see https://bugs.gentoo.org/show_bug.cgi?id=500580#c3
+       local mesa_cards ati_cards nvidia_cards render_cards
+       shopt -s nullglob
+       ati_cards=$(echo -n /dev/ati/card* | sed 's/ /:/g')
+       if test -n "${ati_cards}"; then
+               addpredict "${ati_cards}"
+       fi
+       mesa_cards=$(echo -n /dev/dri/card* | sed 's/ /:/g')
+       if test -n "${mesa_cards}"; then
+               addpredict "${mesa_cards}"
+       fi
+       nvidia_cards=$(echo -n /dev/nvidia** | sed 's/ /:/g')
+       if test -n "${nvidia_cards}"; then
+               addpredict "${nvidia_cards}"
+       fi
+       render_cards=$(echo -n /dev/dri/renderD128* | sed 's/ /:/g')
+       if test -n "${render_cards}"; then
+               addpredict "${render_cards}"
+       fi
+       shopt -u nullglob
+       addpredict /dev/nvidiactl
+}
+
+src_configure() {
+       local depth=16
+       use q8 && depth=8
+       use q32 && depth=32
+
+       local openmp=disable
+       use openmp && { tc-has-openmp && openmp=enable; }
+
+       use perl && perl_check_env
+
+       [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
+
+       local myeconfargs=(
+               $(use_enable static-libs static)
+               $(use_enable hdri)
+               $(use_enable opencl)
+               --with-threads
+               --with-modules
+               --with-quantum-depth=${depth}
+               $(use_with cxx magick-plus-plus)
+               $(use_with perl)
+               --with-perl-options='INSTALLDIRS=vendor'
+               --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
+               $(use_with bzip2 bzlib)
+               $(use_with X x)
+               $(use_with zlib)
+               --without-autotrace
+               $(use_with postscript dps)
+               $(use_with djvu)
+               --with-dejavu-font-dir="${EPREFIX}"/usr/share/fonts/dejavu
+               $(use_with fftw)
+               $(use_with fpx)
+               $(use_with fontconfig)
+               $(use_with truetype freetype)
+               $(use_with postscript gslib)
+               $(use_with graphviz gvc)
+               $(use_with heif heic)
+               $(use_with jbig)
+               $(use_with jpeg)
+               $(use_with jpeg2k openjp2)
+               $(use_with lcms)
+               $(use_with lqr)
+               $(use_with lzma)
+               $(use_with openexr)
+               $(use_with pango)
+               $(use_with png)
+               $(use_with raw)
+               $(use_with svg rsvg)
+               $(use_with tiff)
+               $(use_with webp)
+               $(use_with corefonts windows-font-dir "${EPREFIX}"/usr/share/fonts/corefonts)
+               $(use_with wmf)
+               $(use_with xml)
+               --${openmp}-openmp
+               --with-gcc-arch=no-automagic
+       )
+       CONFIG_SHELL=$(type -P bash) econf "${myeconfargs[@]}"
+}
+
+src_test() {
+       # Install default (unrestricted) policy in $HOME for test suite #664238
+       local _im_local_config_home="${HOME}/.config/ImageMagick"
+       mkdir -p "${_im_local_config_home}" || \
+               die "Failed to create IM config dir in '${_im_local_config_home}'"
+       cp "${FILESDIR}"/policy.test.xml "${_im_local_config_home}/policy.xml" || \
+               die "Failed to install default blank policy.xml in '${_im_local_config_home}'"
+
+       local im_command= IM_COMMANDS=()
+       IM_COMMANDS+=( "identify -version | grep -q -- \"${MY_PV}\"" ) # Verify that we are using version we just built
+       IM_COMMANDS+=( "identify -list policy" ) # Verify that policy.xml is used
+       IM_COMMANDS+=( "emake check" ) # Run tests
+
+       for im_command in "${IM_COMMANDS[@]}"; do
+               eval "${S}"/magick.sh \
+                       ${im_command} || \
+                       die "Failed to run \"${im_command}\""
+       done
+}
+
+src_install() {
+       # Ensure documentation installation files and paths with each release!
+       emake \
+               DESTDIR="${D}" \
+               DOCUMENTATION_PATH="${EPREFIX}"/usr/share/doc/${PF}/html \
+               install
+
+       rm -f "${ED%/}"/usr/share/doc/${PF}/html/{ChangeLog,LICENSE,NEWS.txt}
+       dodoc {AUTHORS,README}.txt ChangeLog
+
+       if use perl; then
+               find "${ED}" -type f -name perllocal.pod -exec rm -f {} +
+               find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} +
+       fi
+
+       find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+       # .la files in parent are not needed, keep plugin .la files
+       rm "${ED}"/usr/$(get_libdir)/*.la || die
+
+       if use opencl; then
+               cat <<-EOF > "${T}"/99${PN}
+               SANDBOX_PREDICT="/dev/nvidiactl:/dev/nvidia-uvm:/dev/ati/card:/dev/dri/card:/dev/dri/renderD128"
+               EOF
+
+               insinto /etc/sandbox.d
+               doins "${T}"/99${PN} #472766
+       fi
+
+       insinto /usr/share/${PN}
+       doins config/*icm
+}
+
+pkg_postinst() {
+       local _show_policy_xml_notice=
+
+       if [[ -z "${REPLACING_VERSIONS}" ]]; then
+               # This is a new installation
+               _show_policy_xml_notice=yes
+       else
+               local v
+               for v in ${REPLACING_VERSIONS}; do
+                       if ! ver_test "${v}" -gt "6.9.10.10-r2"; then
+                               # This is an upgrade
+                               _show_policy_xml_notice=yes
+
+                               # Show this elog only once
+                               break
+                       fi
+               done
+       fi
+
+       if [[ -n "${_show_policy_xml_notice}" ]]; then
+               elog "For security reasons, a policy.xml file was installed in /etc/ImageMagick-6"
+               elog "which will prevent the usage of the following coders by default:"
+               elog ""
+               elog "  - PS"
+               elog "  - PS2"
+               elog "  - PS3"
+               elog "  - EPS"
+               elog "  - PDF"
+               elog "  - XPS"
+       fi
+}
diff --git a/media-gfx/imagemagick/imagemagick-7.0.10.9.ebuild b/media-gfx/imagemagick/imagemagick-7.0.10.9.ebuild
new file mode 100644 (file)
index 0000000..4d2561a
--- /dev/null
@@ -0,0 +1,267 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic libtool perl-functions toolchain-funcs multilib
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/ImageMagick/ImageMagick.git"
+       inherit git-r3
+       MY_P="imagemagick-9999"
+else
+       MY_PV="$(ver_rs 3 '-')"
+       MY_P="ImageMagick-${MY_PV}"
+       SRC_URI="mirror://imagemagick/${MY_P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A collection of tools and libraries for many image formats"
+HOMEPAGE="https://www.imagemagick.org/"
+
+LICENSE="imagemagick"
+SLOT="0/7.0.10"
+IUSE="bzip2 corefonts +cxx djvu fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp wmf X xml zlib"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="corefonts? ( truetype )
+       test? ( corefonts )"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+RDEPEND="
+       dev-libs/libltdl:0
+       bzip2? ( app-arch/bzip2 )
+       corefonts? ( media-fonts/corefonts )
+       djvu? ( app-text/djvu )
+       fftw? ( sci-libs/fftw:3.0 )
+       fontconfig? ( media-libs/fontconfig )
+       fpx? ( >=media-libs/libfpx-1.3.0-r1 )
+       graphviz? ( media-gfx/graphviz )
+       heif? ( media-libs/libheif:= )
+       jbig? ( >=media-libs/jbigkit-2:= )
+       jpeg? ( virtual/jpeg:0 )
+       jpeg2k? ( >=media-libs/openjpeg-2.1.0:2 )
+       lcms? ( media-libs/lcms:2= )
+       lqr? ( media-libs/liblqr )
+       opencl? ( virtual/opencl )
+       openexr? ( media-libs/openexr:0= )
+       pango? ( x11-libs/pango )
+       perl? ( >=dev-lang/perl-5.8.8:0= )
+       png? ( media-libs/libpng:0= )
+       postscript? ( app-text/ghostscript-gpl )
+       raw? ( media-libs/libraw:= )
+       svg? (
+               gnome-base/librsvg
+               media-gfx/potrace
+               )
+       tiff? ( media-libs/tiff:0= )
+       truetype? (
+               media-fonts/urw-fonts
+               >=media-libs/freetype-2
+               )
+       webp? ( media-libs/libwebp:0= )
+       wmf? ( media-libs/libwmf )
+       X? (
+               x11-libs/libICE
+               x11-libs/libSM
+               x11-libs/libXext
+               x11-libs/libXt
+               )
+       xml? ( dev-libs/libxml2:= )
+       lzma? ( app-arch/xz-utils )
+       zlib? ( sys-libs/zlib:= )"
+
+DEPEND="${RDEPEND}
+       !media-gfx/graphicsmagick[imagemagick]
+       X? ( x11-base/xorg-proto )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       default
+
+       # Apply hardening #664236
+       cp "${FILESDIR}"/policy-hardening.snippet "${S}" || die
+       sed -i -e '/^<policymap>$/ {
+                       r policy-hardening.snippet
+                       d
+               }' \
+               config/policy.xml || \
+               die "Failed to apply hardening of policy.xml"
+       einfo "policy.xml hardened"
+
+       elibtoolize # for Darwin modules
+
+       # For testsuite, see https://bugs.gentoo.org/show_bug.cgi?id=500580#c3
+       local ati_cards mesa_cards nvidia_cards render_cards
+       shopt -s nullglob
+       ati_cards=$(echo -n /dev/ati/card* | sed 's/ /:/g')
+       if test -n "${ati_cards}"; then
+               addpredict "${ati_cards}"
+       fi
+       mesa_cards=$(echo -n /dev/dri/card* | sed 's/ /:/g')
+       if test -n "${mesa_cards}"; then
+               addpredict "${mesa_cards}"
+       fi
+       nvidia_cards=$(echo -n /dev/nvidia* | sed 's/ /:/g')
+       if test -n "${nvidia_cards}"; then
+               addpredict "${nvidia_cards}"
+       fi
+       render_cards=$(echo -n /dev/dri/renderD128* | sed 's/ /:/g')
+       if test -n "${render_cards}"; then
+               addpredict "${render_cards}"
+       fi
+       shopt -u nullglob
+       addpredict /dev/nvidiactl
+}
+
+src_configure() {
+       local depth=16
+       use q8 && depth=8
+       use q32 && depth=32
+
+       local openmp=disable
+       use openmp && { tc-has-openmp && openmp=enable; }
+
+       use perl && perl_check_env
+
+       [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
+
+       local myeconfargs=(
+               $(use_enable static-libs static)
+               $(use_enable hdri)
+               $(use_enable opencl)
+               --with-threads
+               --with-modules
+               --with-quantum-depth=${depth}
+               $(use_with cxx magick-plus-plus)
+               $(use_with perl)
+               --with-perl-options='INSTALLDIRS=vendor'
+               --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
+               $(use_with bzip2 bzlib)
+               $(use_with X x)
+               $(use_with zlib)
+               --without-autotrace
+               $(use_with postscript dps)
+               $(use_with djvu)
+               --with-dejavu-font-dir="${EPREFIX}"/usr/share/fonts/dejavu
+               $(use_with fftw)
+               $(use_with fpx)
+               $(use_with fontconfig)
+               $(use_with truetype freetype)
+               $(use_with postscript gslib)
+               $(use_with graphviz gvc)
+               $(use_with heif heic)
+               $(use_with jbig)
+               $(use_with jpeg)
+               $(use_with jpeg2k openjp2)
+               --without-jxl
+               $(use_with lcms)
+               $(use_with lqr)
+               $(use_with lzma)
+               $(use_with openexr)
+               $(use_with pango)
+               $(use_with png)
+               $(use_with raw)
+               $(use_with svg rsvg)
+               $(use_with tiff)
+               $(use_with webp)
+               $(use_with corefonts windows-font-dir "${EPREFIX}"/usr/share/fonts/corefonts)
+               $(use_with wmf)
+               $(use_with xml)
+               --${openmp}-openmp
+               --with-gcc-arch=no-automagic
+       )
+       CONFIG_SHELL=$(type -P bash) econf "${myeconfargs[@]}"
+}
+
+src_test() {
+       # Install default (unrestricted) policy in $HOME for test suite #664238
+       local _im_local_config_home="${HOME}/.config/ImageMagick"
+       mkdir -p "${_im_local_config_home}" || \
+               die "Failed to create IM config dir in '${_im_local_config_home}'"
+       cp "${FILESDIR}"/policy.test.xml "${_im_local_config_home}/policy.xml" || \
+               die "Failed to install default blank policy.xml in '${_im_local_config_home}'"
+
+       local im_command= IM_COMMANDS=()
+       if [[ ${PV} == "9999" ]] ; then
+               IM_COMMANDS+=( "magick -version" ) # Show version we are using -- cannot verify because of live ebuild
+       else
+               IM_COMMANDS+=( "magick -version | grep -q -- \"${MY_PV}\"" ) # Verify that we are using version we just built
+       fi
+       IM_COMMANDS+=( "magick -list policy" ) # Verify that policy.xml is used
+       IM_COMMANDS+=( "emake check" ) # Run tests
+
+       for im_command in "${IM_COMMANDS[@]}"; do
+               eval "${S}"/magick.sh \
+                       ${im_command} || \
+                       die "Failed to run \"${im_command}\""
+       done
+}
+
+src_install() {
+       # Ensure documentation installation files and paths with each release!
+       emake \
+               DESTDIR="${D}" \
+               DOCUMENTATION_PATH="${EPREFIX}"/usr/share/doc/${PF}/html \
+               install
+
+       rm -f "${ED}"/usr/share/doc/${PF}/html/{ChangeLog,LICENSE,NEWS.txt}
+       dodoc {AUTHORS,README}.txt ChangeLog
+
+       if use perl; then
+               find "${ED}" -type f -name perllocal.pod -exec rm -f {} +
+               find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} +
+       fi
+
+       find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+       # .la files in parent are not needed, keep plugin .la files
+       rm "${ED}"/usr/$(get_libdir)/*.la || die
+
+       if use opencl; then
+               cat <<-EOF > "${T}"/99${PN}
+               SANDBOX_PREDICT="/dev/nvidiactl:/dev/nvidia-uvm:/dev/ati/card:/dev/dri/card:/dev/dri/renderD128"
+               EOF
+
+               insinto /etc/sandbox.d
+               doins "${T}"/99${PN} #472766
+       fi
+
+       insinto /usr/share/${PN}
+       doins config/*icm
+}
+
+pkg_postinst() {
+       local _show_policy_xml_notice=
+
+       if [[ -z "${REPLACING_VERSIONS}" ]]; then
+               # This is a new installation
+               _show_policy_xml_notice=yes
+       else
+               local v
+               for v in ${REPLACING_VERSIONS}; do
+                       if ! ver_test "${v}" -gt "7.0.8.10-r2"; then
+                               # This is an upgrade
+                               _show_policy_xml_notice=yes
+
+                               # Show this elog only once
+                               break
+                       fi
+               done
+       fi
+
+       if [[ -n "${_show_policy_xml_notice}" ]]; then
+               elog "For security reasons, a policy.xml file was installed in /etc/ImageMagick-7"
+               elog "which will prevent the usage of the following coders by default:"
+               elog ""
+               elog "  - PS"
+               elog "  - PS2"
+               elog "  - PS3"
+               elog "  - EPS"
+               elog "  - PDF"
+               elog "  - XPS"
+       fi
+}