x11-themes/haematite-xcursors: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 21:56:46 +0000 (23:56 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 21:56:46 +0000 (23:56 +0200)
Bug: https://bugs.gentoo.org/697134
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
x11-themes/haematite-xcursors/haematite-xcursors-1.0.ebuild

index 8d8aec2e7980b28046c14dd5f092071685cb5308..dab4234c4ccfa88216e4b7eb54dd143d9d920e68 100644 (file)
@@ -1,9 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
+
+MY_PN="${PN/-xcursors/}"
 
-MY_PN=${PN/-xcursors/}
 DESCRIPTION="A simple crispy dark-grey xcursor theme"
 HOMEPAGE="http://www.kde-look.org/content/show.php/Haematite?content=19594"
 SRC_URI="http://www.kde-look.org/CONTENT/content-files/19594-${MY_PN}-${PV}.tar.gz"
@@ -11,16 +12,12 @@ SRC_URI="http://www.kde-look.org/CONTENT/content-files/19594-${MY_PN}-${PV}.tar.
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
 
 S="${WORKDIR}/${MY_PN}-${PV}"
 
 src_install() {
        insinto /usr/share/cursors/xorg-x11/${MY_PN}
-       doins -r ${MY_PN}/cursors || die "doins failed"
+       doins -r ${MY_PN}/cursors
 }
 
 pkg_postinst() {
@@ -32,7 +29,7 @@ pkg_postinst() {
        elog "Xcursor.size: 48"
        elog
        elog "Also, to globally use this set of mouse cursors edit the file:"
-       elog "    /usr/share/cursors/xorg-x11/default/index.theme"
+       elog "    ${EROOT}/usr/share/cursors/xorg-x11/default/index.theme"
        elog "and change the line:"
        elog "    Inherits=[current setting]"
        elog "to"
@@ -40,6 +37,7 @@ pkg_postinst() {
        elog
        elog "Note this will be overruled by a user's ~/.Xdefaults file."
        elog
+
        ewarn "If you experience flickering, try setting the following line in"
        ewarn "the Device section of your xorg.conf file:"
        ewarn "    Option  \"HWCursor\"  \"false\""