media-libs/mesa: Update to use upstream glx-read-only-text flag.
authorMatt Turner <mattst88@gentoo.org>
Mon, 21 Sep 2015 19:51:19 +0000 (12:51 -0700)
committerMatt Turner <mattst88@gentoo.org>
Mon, 21 Sep 2015 19:51:42 +0000 (12:51 -0700)
Package-Manager: portage-2.2.20.1

media-libs/mesa/mesa-9999.ebuild

index d166219537e8672a57ac1a979a26a74e2fcdebc0..e7cf9a92e44e13382bccdd00798d3d6736e1b62c 100644 (file)
@@ -191,10 +191,7 @@ pkg_setup() {
 }
 
 src_prepare() {
-       # fix for hardened pax_kernel, bug 240956
-       [[ ${PV} != 9999* ]] && epatch "${FILESDIR}"/glx_ro_text_segm.patch
-
-       eautoreconf
+       [[ ${PV} == 9999 ]] && eautoreconf
 }
 
 multilib_src_configure() {
@@ -268,11 +265,9 @@ multilib_src_configure() {
                fi
        fi
 
-       # x86 hardened pax_kernel needs glx-rts, bug 240956
+       # x86 hardened pax_kernel needs glx-read-only-text, bug 240956
        if use pax_kernel; then
-               myconf+="
-                       $(use_enable x86 glx-rts)
-               "
+               myconf+="$(use_enable x86 glx-read-only-text)"
        fi
 
        # on abi_x86_32 hardened we need to have asm disable