Revert "Revert dev-python/pyzmq py2 and net-wireless/urh update"
authorRick Farina <zerochaos@gentoo.org>
Wed, 26 Feb 2020 17:28:58 +0000 (12:28 -0500)
committerRick Farina <zerochaos@gentoo.org>
Wed, 26 Feb 2020 17:28:58 +0000 (12:28 -0500)
This reverts commit 2294f62841656970a6a9164115df73fc41cd279a.

Signed-off-by: Rick Farina <zerochaos@gentoo.org>
dev-python/pyzmq/pyzmq-16.0.2.ebuild
dev-python/pyzmq/pyzmq-17.1.0.ebuild
net-wireless/urh/urh-2.8.3-r1.ebuild [moved from net-wireless/urh/urh-2.8.3.ebuild with 95% similarity]
net-wireless/urh/urh-9999.ebuild

index c6f982a73c2647f6b8600ad324b93b064daa2df3..914737e0cb2b70a5ab9ca5cef03552e5911d0c7b 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
 PYTHON_REQ_USE="threads(+)"
 
 inherit flag-o-matic distutils-r1 toolchain-funcs
@@ -22,11 +22,13 @@ RDEPEND="
        >=net-libs/zeromq-4.1.2:=
        dev-python/py[${PYTHON_USEDEP}]
        dev-python/cffi:=[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
 "
 DEPEND="${RDEPEND}
        dev-python/cython[${PYTHON_USEDEP}]
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
                www-servers/tornado[${PYTHON_USEDEP}]
        )
        doc? (
@@ -51,6 +53,7 @@ python_compile_all() {
 
 python_compile() {
        esetup.py cython --force
+       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
        distutils-r1_python_compile
 }
 
index e7d8b211d8069a952e541c4f9bc1891be4e66e97..90216948f4ff7562d5d861d9ac8577e560174a6f 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
 PYTHON_REQ_USE="threads(+)"
 
 inherit flag-o-matic distutils-r1 toolchain-funcs
@@ -22,11 +22,13 @@ RDEPEND="
        >=net-libs/zeromq-4.2.2-r2:=[drafts]
        dev-python/py[${PYTHON_USEDEP}]
        dev-python/cffi:=[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
 "
 DEPEND="${RDEPEND}
        dev-python/cython[${PYTHON_USEDEP}]
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
                >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
        )
        doc? (
@@ -53,6 +55,7 @@ python_compile_all() {
 
 python_compile() {
        esetup.py cython --force
+       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
        distutils-r1_python_compile
 }
 
similarity index 95%
rename from net-wireless/urh/urh-2.8.3.ebuild
rename to net-wireless/urh/urh-2.8.3-r1.ebuild
index 1c4f6ddf86f1f78e3e04e6979b3175fff8d0679f..c5cc8e3ff712d91e9dc454a5e8bfd26c749ce9db 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
 inherit distutils-r1 eutils
@@ -26,7 +26,7 @@ DEPEND="${PYTHON_DEPS}
                net-wireless/gnuradio[zeromq]
                dev-python/numpy[${PYTHON_USEDEP}]
                dev-python/psutil[${PYTHON_USEDEP}]
-               dev-python/pyzmq[${PYTHON_USEDEP}]
+               dev-python/pyzmq[python_targets_python2_7]
                dev-python/cython[${PYTHON_USEDEP}]
                bladerf? ( net-wireless/bladerf:= )
                hackrf? ( net-libs/libhackrf:= )
index 1c4f6ddf86f1f78e3e04e6979b3175fff8d0679f..c5cc8e3ff712d91e9dc454a5e8bfd26c749ce9db 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 PYTHON_COMPAT=( python3_6 )
 inherit distutils-r1 eutils
@@ -26,7 +26,7 @@ DEPEND="${PYTHON_DEPS}
                net-wireless/gnuradio[zeromq]
                dev-python/numpy[${PYTHON_USEDEP}]
                dev-python/psutil[${PYTHON_USEDEP}]
-               dev-python/pyzmq[${PYTHON_USEDEP}]
+               dev-python/pyzmq[python_targets_python2_7]
                dev-python/cython[${PYTHON_USEDEP}]
                bladerf? ( net-wireless/bladerf:= )
                hackrf? ( net-libs/libhackrf:= )