net-analyzer/linkchecker: sync live ebuild
authorTomas Mozes <hydrapolic@gmail.com>
Fri, 18 Jan 2019 12:36:36 +0000 (13:36 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 19 Jan 2019 03:21:46 +0000 (04:21 +0100)
Package-Manager: Portage-2.3.55, Repoman-2.3.12
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/10860
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
net-analyzer/linkchecker/linkchecker-9999.ebuild

index 81a23e9d21b6fc63fe363a5fef47a40c1eabb99b..528d4f9fc6ccde2d7c93c2fd87edfa17932dfb1f 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="sqlite?"
@@ -16,29 +16,31 @@ SRC_URI=""
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="gnome sqlite"
+IUSE="sqlite"
 
 RDEPEND="
        dev-python/pyxdg[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.4[${PYTHON_USEDEP}]
        virtual/python-dnspython[${PYTHON_USEDEP}]
-       gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
 "
 DEPEND=""
 
 RESTRICT="test"
 
 python_prepare_all() {
-       local PATCHES=( "${FILESDIR}"/${PN}-9.3-bash-completion.patch )
+       local PATCHES=(
+               "${FILESDIR}/${PN}-9.3-bash-completion.patch"
+       )
 
        distutils-r1_python_prepare_all
 }
 
 python_install_all() {
        DOCS=(
-               doc/upgrading.txt
-               doc/python3.txt
                doc/changelog.txt
                doc/development.mdwn
+               doc/python3.txt
+               doc/upgrading.txt
        )
        distutils-r1_python_install_all