dev-python/oslo-rootwrap: cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 18:32:09 +0000 (12:32 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 19:06:02 +0000 (13:06 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/oslo-rootwrap/Manifest
dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild [deleted file]

index 4b2df6e21adc104a5e81615dae16a5074e96f6dd..4550522015118ff38b6897306e0b6df6584bf2c4 100644 (file)
@@ -1,2 +1 @@
-DIST oslo.rootwrap-5.13.0.tar.gz 43433 BLAKE2B 8d53587f63022255683d18b8ce22dca07a160d7692e9d2fcd5e6c466bb6969da11a9a1af4646809921724b9f1b63b2532728bd3ade82312354793b6b4d15f0d4 SHA512 ff716e1e5900f754617578eb8bf60c1d2794474706f22a0c619c94177602ed3c3acde42ad499a7a613f310d6dffe526339b5cd1c96ecc727dcc43e1a9afd606c
 DIST oslo.rootwrap-5.15.2.tar.gz 45566 BLAKE2B 1755a52d1e380a512c50f5314f7a4f249da9e62030abfef531bf973277a98f1f42f1c27a69a4e6e5cf64441e6a7263a3780355da4860461cfafed172ea087946 SHA512 9fc4c4678a25ebecb08026e71ef8da44bf1214f177d5330de8d68cfce8c3d85f4085a9e19f282bc8b498a36d8a7e384cde354a95619a800e3a68aba088df5aad
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild
deleted file mode 100644 (file)
index 92c9f19..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
-HOMEPAGE="https://pypi.org/project/oslo.config/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
-S="${WORKDIR}/oslo.rootwrap-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
-               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
-               >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
-               !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
-               <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
-               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
-               >dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
-       nosetests tests/ || die "test failed under ${EPYTHON}"
-}