net-misc/freerdp: add logic for libswscale / cairo
authorMike Gilbert <floppym@gentoo.org>
Thu, 12 Dec 2019 21:39:17 +0000 (16:39 -0500)
committerMike Gilbert <floppym@gentoo.org>
Thu, 12 Dec 2019 21:40:02 +0000 (16:40 -0500)
Closes: https://bugs.gentoo.org/698392
Package-Manager: Portage-2.3.80_p5, Repoman-2.3.19_p4
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
net-misc/freerdp/freerdp-9999.ebuild

index 7c33bd96354a718946118c9e4e186800b62e2a63..e76413183e5d82260a3cd77ab75611a635b63ed4 100644 (file)
@@ -20,7 +20,7 @@ HOMEPAGE="http://www.freerdp.com/"
 
 LICENSE="Apache-2.0"
 SLOT="0/2"
-IUSE="alsa +client cpu_flags_arm_neon cups debug doc ffmpeg gstreamer jpeg libav libressl openh264 pulseaudio server smartcard systemd test usb wayland X xinerama xv"
+IUSE="alsa +client cpu_flags_arm_neon cups debug doc +ffmpeg gstreamer jpeg libav libressl openh264 pulseaudio server smartcard systemd test usb wayland X xinerama xv"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
@@ -49,6 +49,9 @@ RDEPEND="
                libav? ( media-video/libav:0= )
                !libav? ( media-video/ffmpeg:0= )
        )
+       !ffmpeg? (
+               x11-libs/cairo:0=
+       )
        gstreamer? (
                media-libs/gstreamer:1.0
                media-libs/gst-plugins-base:1.0
@@ -103,6 +106,8 @@ src_configure() {
                -DWITH_DEBUG_ALL=$(usex-on-off debug)
                -DWITH_MANPAGES=$(usex-on-off doc)
                -DWITH_FFMPEG=$(usex-on-off ffmpeg)
+               -DWITH_SWSCALE=$(usex-on-off ffmpeg)
+               -DWITH_CAIRO=$(usex ffmpeg OFF ON)
                -DWITH_DSP_FFMPEG=$(usex-on-off ffmpeg)
                -DWITH_GSTREAMER_1_0=$(usex-on-off gstreamer)
                -DWITH_JPEG=$(usex-on-off jpeg)