dev-perl/Algorithm-ClusterPoints: Add EAPI7
authorKent Fredric <kentnl@gentoo.org>
Thu, 23 Apr 2020 00:00:15 +0000 (12:00 +1200)
committerKent Fredric <kentnl@gentoo.org>
Thu, 23 Apr 2020 01:55:32 +0000 (13:55 +1200)
Cleaned up some output cruft in the process

Removed explicit LICENSE= to use default, which better reflects
what is true when upstream specifies "the perl license"

But upstream says "perl 5.8.8, or any later perl 5"

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Algorithm-ClusterPoints/Algorithm-ClusterPoints-0.80.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Algorithm-ClusterPoints/Algorithm-ClusterPoints-0.80.0-r1.ebuild b/dev-perl/Algorithm-ClusterPoints/Algorithm-ClusterPoints-0.80.0-r1.ebuild
new file mode 100644 (file)
index 0000000..4b46224
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=SALVA
+DIST_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="Find clusters inside a set of points"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# License note: says 'perl 5.8.8 or any later' bug #718946
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? ( virtual/perl-Test-Simple )
+"
+PERL_RM_FILES=(
+       "t/pods.t"
+)