dev-tex/biblatex: add biber use flag
authorHendrik v. Raven <hendrik@consetetur.de>
Fri, 19 May 2017 13:35:31 +0000 (15:35 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 30 May 2017 08:01:05 +0000 (10:01 +0200)
biber is the default backend for biblatex for several versions now and
supersedes the old bibtex and bibtex8 backends.

Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-tex/biblatex/biblatex-3.7-r1.ebuild [new file with mode: 0644]
dev-tex/biblatex/metadata.xml

diff --git a/dev-tex/biblatex/biblatex-3.7-r1.ebuild b/dev-tex/biblatex/biblatex-3.7-r1.ebuild
new file mode 100644 (file)
index 0000000..bae0958
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit latex-package
+
+DESCRIPTION="Reimplementation of the bibliographic facilities provided by LaTeX"
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/biblatex https://github.com/plk/biblatex/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tds.tgz"
+
+LICENSE="LPPL-1.3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+biber doc examples"
+
+DEPEND="dev-texlive/texlive-bibtexextra
+       dev-texlive/texlive-latexextra
+       dev-texlive/texlive-genericextra"
+RDEPEND="${DEPEND}
+       biber? ( ~dev-tex/biber-2.7 )"
+
+S="${WORKDIR}"
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+       insinto "${TEXMF}"
+       doins -r bibtex tex
+
+       dodoc doc/latex/biblatex/{README,CHANGES.org}
+       if use doc ; then
+               pushd doc || die
+               latex-package_src_doinstall doc
+               popd || die
+       fi
+
+       if use examples ; then
+               dodoc -r doc/latex/biblatex/examples
+       fi
+}
index da3be4fdc721668dc0f31da8b5121cebc48d58f3..594b23863aae679f20952168d94b128ca6faf1b0 100644 (file)
@@ -13,6 +13,9 @@
                <email>tex@gentoo.org</email>
                <name>Gentoo TeX Project</name>
        </maintainer>
+       <use>
+               <flag name="biber">Install the unicode compatible backend processor</flag>
+       </use>
        <upstream>
                <remote-id type="github">plk/biblatex</remote-id>
                <remote-id type="sourceforge">biblatex</remote-id>