dev-python/beautifulsoup: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 16:23:39 +0000 (18:23 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 11 May 2020 16:48:44 +0000 (18:48 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/beautifulsoup/Manifest
dev-python/beautifulsoup/beautifulsoup-4.8.1.ebuild [deleted file]

index 7fde3fdb2197eff5eb2d3173dddb0f12096b212c..c92891dad8067141aaff2984f5999ab462baec46 100644 (file)
@@ -1,2 +1 @@
-DIST beautifulsoup4-4.8.1.tar.gz 159164 BLAKE2B 00121e9b30f700ade0bb2ec8f637b4173ecb4c187b8f9a77bcc4e6b333fced85a699c8d9efa5b757ab02f54c2b05740702c13625ff427730ccc1f6a97f43fa48 SHA512 7abc5e84cb8da5428dafc6b473418d0cc72b518cb1a73d4ae58b8dad3ec985e5778629dc1d7c8374dfb223be981983c745a1dbb55a98078b4cfe7ba5ce25539b
 DIST beautifulsoup4-4.8.2.tar.gz 298650 BLAKE2B 6826abf793efa63be89d844bc25bdb105413196bfab21c18f3816fd59a7a771459bf2c7ee209b75b0c88dfa14da8f4625c948889acfb48502e2260ccca229675 SHA512 aab90eb22614e9a2fb47792389a951b3ad7faf9791e15984a6c27a38be6f3d0ccbf3a9753d9afb5c70105097ac1a9c5f9e07206e12c6d4cb7a7f6d4e90ec18c2
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.8.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.8.1.ebuild
deleted file mode 100644 (file)
index 5909b95..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="${PN}4"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
-HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
-
-# html5lib is optional however hard coding since its use is actively discouraged in the devmanual
-RDEPEND="
-       dev-python/soupsieve[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/html5lib[${PYTHON_USEDEP}]' python2_7 pypy)
-       $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' python2_7 'python3*')
-"
-BDEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-distutils_enable_tests nose
-distutils_enable_sphinx doc/source --no-autodoc
-
-python_test() {
-       nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
-}