net-misc/netctl: Use optfeature from eutils.eclass
authorJustin Lecher <jlec@gentoo.org>
Sat, 12 Sep 2015 10:36:30 +0000 (12:36 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sat, 12 Sep 2015 10:36:30 +0000 (12:36 +0200)
Package-Manager: portage-2.2.20
Signed-off-by: Justin Lecher <jlec@gentoo.org>
net-misc/netctl/netctl-1.10.ebuild
net-misc/netctl/netctl-1.9.ebuild
net-misc/netctl/netctl-9999.ebuild

index 88a933e680b8bdc1c8c0127f113b07d432b65c91..4a6ba6fb7d380fdb0eeff1bed1c37ba067bb5b47 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit bash-completion-r1
+inherit bash-completion-r1 eutils
 
 if [[ ${PV} = *9999* ]]; then
        EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
@@ -54,19 +54,6 @@ src_install() {
        newins contrib/zsh-completion _netctl
 }
 
-optfeature() {
-       local desc=$1
-       shift
-       while (( $# )); do
-               if has_version "$1"; then
-                       elog "  [I] $1 for ${desc}"
-               else
-                       elog "  [ ] $1 for ${desc}"
-               fi
-               shift
-       done
-}
-
 pkg_postinst() {
        if [[ -z ${REPLACING_VERSIONS} ]]; then
                elog "To get additional features, a number of optional runtime dependencies may be"
index 8fd90dca186204859f57556133b72ea9a913cbfa..cf44dd20c24c8ae035d29bf711f7e3a2f440d4cd 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit bash-completion-r1
+inherit bash-completion-r1 eutils
 
 if [[ ${PV} = *9999* ]]; then
        EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
@@ -54,19 +54,6 @@ src_install() {
        newins contrib/zsh-completion _netctl
 }
 
-optfeature() {
-       local desc=$1
-       shift
-       while (( $# )); do
-               if has_version "$1"; then
-                       elog "  [I] $1 for ${desc}"
-               else
-                       elog "  [ ] $1 for ${desc}"
-               fi
-               shift
-       done
-}
-
 pkg_postinst() {
        if [[ -z ${REPLACING_VERSIONS} ]]; then
                elog "To get additional features, a number of optional runtime dependencies may be"
index 87bbb92b396bed2edf091d06a538b250660033fa..d85787dd2937fc66d6f7106a2fdf416b51393de2 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
 
-inherit bash-completion-r1
+inherit bash-completion-r1 eutils
 
 if [[ ${PV} = *9999* ]]; then
        EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
@@ -53,19 +53,6 @@ src_install() {
        newins contrib/zsh-completion _netctl
 }
 
-optfeature() {
-       local desc=$1
-       shift
-       while (( $# )); do
-               if has_version "$1"; then
-                       elog "  [I] $1 for ${desc}"
-               else
-                       elog "  [ ] $1 for ${desc}"
-               fi
-               shift
-       done
-}
-
 pkg_postinst() {
        if [[ -z ${REPLACING_VERSIONS} ]]; then
                elog "To get additional features, a number of optional runtime dependencies may be"