dev-util/sysdig: Make CONFIG_TRACEPOINTS check non-fatal
authorJustin Lecher <jlec@gentoo.org>
Mon, 28 Sep 2015 11:50:56 +0000 (13:50 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 28 Sep 2015 11:50:56 +0000 (13:50 +0200)
Package-Manager: portage-2.2.22
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-util/sysdig/metadata.xml
dev-util/sysdig/sysdig-0.1.104.ebuild
dev-util/sysdig/sysdig-0.1.92.ebuild
dev-util/sysdig/sysdig-0.1.98.ebuild

index 33c7008e71d742d274d6443c06f2d1fb53c58652..059917e98ca06acc5c667953fadc193244df921e 100644 (file)
@@ -6,7 +6,7 @@
                <name>Michał Górny</name>
        </maintainer>
        <use>
-               <flag name='modules'>Build kernel modules needed for tracing local
+               <flag name="modules">Build kernel modules needed for tracing local
                        events. Disable this only if you intend to use sysdig purely
                        to work with dumpfiles.</flag>
        </use>
index dbd0e94bf4aa513b1d7bd53b09533f28c57b3029..0c4d00a5cf57676e46c0e9b0a16d480381cf3886 100644 (file)
@@ -15,7 +15,8 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="+modules"
 
-RDEPEND="dev-lang/luajit:2=
+RDEPEND="
+       dev-lang/luajit:2=
        >=dev-libs/jsoncpp-0.6_pre:0=
        sys-libs/ncurses:0=
        sys-libs/zlib:0="
@@ -24,7 +25,7 @@ DEPEND="${RDEPEND}
        virtual/os-headers"
 
 # needed for the kernel module
-CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS TRACEPOINTS"
+CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
 
 pkg_pretend() {
        use modules && linux-mod_pkg_setup
index 2ee127782d62274d8505082273f4b0c627d36e46..b4771410baf66dafa67caf32516f51c8066b8409 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -16,7 +16,8 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="+modules"
 
-RDEPEND="dev-lang/luajit:2=
+RDEPEND="
+       dev-lang/luajit:2=
        dev-libs/jsoncpp:0=
        sys-libs/zlib:0="
 DEPEND="${RDEPEND}
@@ -24,7 +25,7 @@ DEPEND="${RDEPEND}
        virtual/os-headers"
 
 # needed for the kernel module
-CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS TRACEPOINTS"
+CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
 
 pkg_pretend() {
        use modules && linux-mod_pkg_setup
index 01698892aab559db38953a68d2dd786f54767411..bf9e04be27dd267472264305414d83dd24491a7d 100644 (file)
@@ -16,7 +16,8 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="+modules"
 
-RDEPEND="dev-lang/luajit:2=
+RDEPEND="
+       dev-lang/luajit:2=
        >=dev-libs/jsoncpp-0.6_pre:0=
        sys-libs/zlib:0="
 DEPEND="${RDEPEND}
@@ -24,7 +25,7 @@ DEPEND="${RDEPEND}
        virtual/os-headers"
 
 # needed for the kernel module
-CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS TRACEPOINTS"
+CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
 
 pkg_pretend() {
        use modules && linux-mod_pkg_setup