dev-python/plumbum: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:53:53 +0000 (12:53 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:59:30 +0000 (12:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/plumbum/Manifest
dev-python/plumbum/files/plumbum-1.6.4.patch [deleted file]
dev-python/plumbum/plumbum-1.6.4.ebuild [deleted file]
dev-python/plumbum/plumbum-1.6.7.ebuild [deleted file]

index 4b3ca674126a51f4e827867815d8953d4e695273..45881ad7b60f0404ad857cef1fa183744ec71c0a 100644 (file)
@@ -1,3 +1 @@
-DIST plumbum-1.6.4.tar.gz 88041 BLAKE2B aadd929fc6878bd49ac3169b1b4235140d08ff452eb5eb61e43f9ad869ea867916d76ee7f2befb68e67cdd9d9b19c364d6e02810866f6ba5022cf7064d240786 SHA512 26110741251d75ae9b47f522aba38e8af7a658d22900b1487b3f6e4e6971e4682283003e674f40345e14dd4103f6d485fc569348cc1245ac0440cd04688abe99
-DIST plumbum-1.6.7.tar.gz 90911 BLAKE2B fbd7399962288826c9b1aa9eda60e93d2257b02c8d14adda02cd1c6a895941b0adda8cb844b2137e3235dbf5ca7ebfe7e272d3cfafe7e3df8ab3668be75a4fc3 SHA512 70a80a77eb64e483cf0444745a4c05c8599711ea578a61fe3969edceba4a9f68ca226c6d8cb65995ad36f3d6423326af887816c5ffd337f20279dfff47cb59b4
 DIST plumbum-1.6.8.tar.gz 309449 BLAKE2B 4112cb99852ebc7e4465ec54bf35a1352ff41a7ac084d3561d23f6da62fb1b25fa65a1f6f118564a677e6b6fde57b52f964a07fb71cae40b7d831ceb1505738e SHA512 2e834b6024ed1892eb91ede95f70641288a76911d58fcb24edaed59d3e54afa72e0533b4510896ecdd5077f70d4d60d9ceb06510c3e6d469afb1befae1961af1
diff --git a/dev-python/plumbum/files/plumbum-1.6.4.patch b/dev-python/plumbum/files/plumbum-1.6.4.patch
deleted file mode 100644 (file)
index ce18d7a..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -r -U2 plumbum-1.6.4.orig/plumbum/cli/image.py plumbum-1.6.4/plumbum/cli/image.py
---- plumbum-1.6.4.orig/plumbum/cli/image.py    2017-11-08 21:20:49.000000000 +0700
-+++ plumbum-1.6.4/plumbum/cli/image.py 2017-12-15 15:45:16.184943092 +0700
-@@ -3,5 +3,6 @@
- from plumbum import colors
- from .termsize import get_terminal_size
--import . as cli
-+from .application import Application
-+from .switches import switch, SwitchAttr, Flag, positional, Range, ExistingFile
- import sys
-@@ -75,17 +76,17 @@
-         print(colors.reset)
--class ShowImageApp(cli.Application):
-+class ShowImageApp(Application):
-     'Display an image on the terminal'
--    double = cli.Flag(['-d','--double'], help="Double resolution (only looks good with some fonts)")
-+    double = Flag(['-d','--double'], help="Double resolution (only looks good with some fonts)")
--    @cli.switch(['-c','--colors'], cli.Range(1,4), help="Level of color, 1-4")
-+    @switch(['-c','--colors'], Range(1,4), help="Level of color, 1-4")
-     def colors_set(self, n):
-         colors.use_color = n
--    size = cli.SwitchAttr(['-s','--size'], help="Size, should be in the form 100x150")
-+    size = SwitchAttr(['-s','--size'], help="Size, should be in the form 100x150")
--    ratio = cli.SwitchAttr(['--ratio'], float, default=2.45, help="Aspect ratio of the font")
-+    ratio = SwitchAttr(['--ratio'], float, default=2.45, help="Aspect ratio of the font")
--    @cli.positional(cli.ExistingFile)
-+    @positional(ExistingFile)
-     def main(self, filename):
diff --git a/dev-python/plumbum/plumbum-1.6.4.ebuild b/dev-python/plumbum/plumbum-1.6.4.ebuild
deleted file mode 100644 (file)
index 5c555ac..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="A library for shell script-like programs in python"
-HOMEPAGE="https://plumbum.readthedocs.io/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-PATCHES=( "${FILESDIR}"/${P}.patch )
diff --git a/dev-python/plumbum/plumbum-1.6.7.ebuild b/dev-python/plumbum/plumbum-1.6.7.ebuild
deleted file mode 100644 (file)
index 365b8b1..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="A library for shell script-like programs in python"
-HOMEPAGE="https://plumbum.readthedocs.io/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""