net-wireless/gr-ppm-wiegand: initial ebuild
authorRick Farina <zerochaos@gentoo.org>
Thu, 26 Mar 2020 20:19:01 +0000 (16:19 -0400)
committerRick Farina <zerochaos@gentoo.org>
Thu, 26 Mar 2020 20:20:07 +0000 (16:20 -0400)
https://github.com/redsand/gr-ppm-wiegand/issues/1

Package-Manager: Portage-2.3.95, Repoman-2.3.21
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
net-wireless/gr-ppm-wiegand/gr-ppm-wiegand-9999.ebuild [new file with mode: 0644]
net-wireless/gr-ppm-wiegand/metadata.xml [new file with mode: 0644]

diff --git a/net-wireless/gr-ppm-wiegand/gr-ppm-wiegand-9999.ebuild b/net-wireless/gr-ppm-wiegand/gr-ppm-wiegand-9999.ebuild
new file mode 100644 (file)
index 0000000..793f572
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="GnuRadio PPM (Differential Pulse Position Modulation/Demodulation) plugin"
+HOMEPAGE="https://github.com/redsand/gr-ppm-wiegand"
+if [ "${PV}" = "9999" ]; then
+       EGIT_REPO_URI="https://github.com/redsand/gr-ppm-wiegand.git"
+       inherit git-r3
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/redsand/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+       >=net-wireless/gnuradio-3.7.0:="
+
+DEPEND="${RDEPEND}
+       dev-libs/boost:=
+       dev-util/cppunit"
diff --git a/net-wireless/gr-ppm-wiegand/metadata.xml b/net-wireless/gr-ppm-wiegand/metadata.xml
new file mode 100644 (file)
index 0000000..4c5cd62
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>zerochaos@gentoo.org</email>
+               <name>Rick Farina</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>radio@gentoo.org</email>
+               <name>Radio</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">redsand/gr-ppm-wiegand</remote-id>
+       </upstream>
+</pkgmetadata>