dev-util/rr: run tests only under FEATURE=-usersandbox
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 12 Nov 2019 22:43:56 +0000 (22:43 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 12 Nov 2019 22:45:09 +0000 (22:45 +0000)
rr extensively uses ptrace() to set memory up for replays.
sandbox is also using ptrace() extensively.

As a result 'rr' can't use ptrace() at all:
```
[FATAL rr-5.2.0-r1/work/rr-5.2.0/src/Task.cc:2239:write_bytes_helper()
    errno: EIO]
 (task 967940 (rec:967602) at time 18)
 -> Assertion `nwritten == buf_size' failed to hold. Should have
   written 144 bytes to 0x7fff573a98a0, but only wrote -1
```

Similar to strace test suite allow running tests only under
FEATURES=-usersandbox.

This makes most tests to start passing for me.

Reported-by: Toralf Förster
Bug: https://bugs.gentoo.org/632394
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-util/rr/rr-5.2.0-r1.ebuild

index b621d7b200924a93080498eda660e546edc088ef..b673656cf02f44e17f6ad12765e4f756f6447334 100644 (file)
@@ -53,6 +53,15 @@ src_prepare() {
        sed -i 's:-Werror::' CMakeLists.txt || die #609192
 }
 
+src_test() {
+       if has usersandbox ${FEATURES} ; then
+               ewarn "Test suite fails under FEATURES=usersandbox (bug #632394). Skipping."
+               return 0
+       fi
+
+       cmake-utils_src_test
+}
+
 src_configure() {
        local mycmakeargs=(
                -DBUILD_TESTS=$(usex test)