net-im/zoom: Version bump to 3.5.383291.0407.
authorUlrich Müller <ulm@gentoo.org>
Fri, 10 Apr 2020 21:17:12 +0000 (23:17 +0200)
committerUlrich Müller <ulm@gentoo.org>
Fri, 10 Apr 2020 21:18:49 +0000 (23:18 +0200)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
net-im/zoom/Manifest
net-im/zoom/zoom-3.5.383291.0407.ebuild [new file with mode: 0644]

index 3f6534909a3a7309612587218c2099e7b53f1af6..e8f529918218035bc62b524ceb1a3e19fdba367c 100644 (file)
@@ -2,3 +2,5 @@ DIST zoom-3.5.374815.0324_i686.tar.xz 48481420 BLAKE2B 5c40be4c5cf1e72766f35ea97
 DIST zoom-3.5.374815.0324_x86_64.tar.xz 72609300 BLAKE2B 2f51eecd88cc636f03778c68101b2c5919982025232da5cd6a378a2e681ad76d39d9db201ff14d5601498495909dfb934ebf21752cd7658ada6edc28379bed90 SHA512 632002b6942f15e1f22ba147de9a9463253c2b374e4382b4c2ce21e5685ad4fd688929141095d09e2fa0ed2adb5b0dc6ba9aba2e4fa54ae69fea24b95bf474c4
 DIST zoom-3.5.382995.0407_i686.tar.xz 48494772 BLAKE2B 13d678c36bac7e5705cc0608d0ca49d943e56b492cce802f41ffe6bbb307336fef4e710346f33e596faa84a449b1f69ef944e462b694aff016051a834e1d2a89 SHA512 339abb803cd08e6835404ff2f1140b9ee73294a8820828d833b64e3bfe619fd24eb18c475b78a0f795a63dadc8ffd6593563710d6e8ba606fcbf3ffd7a007c33
 DIST zoom-3.5.382995.0407_x86_64.tar.xz 72616840 BLAKE2B 3a20f9346305ec84c6b14233724dce6ab285810e7c59ed482139e902f088e2cf7f1f48d769fe0f0990128f92aa4221f7fe5f69e9d5859fc5bf6d57378ec25507 SHA512 d0612f83d23e93e84db5dd18c55ebc6b3cba17b9479ff812276e0d1fb21fb9fbe2fe5f38329f5e30cd7acf6c7f88fdf09d6dd31d223e3edec0bc1142b358bb8b
+DIST zoom-3.5.383291.0407_i686.tar.xz 48489396 BLAKE2B cfce6356e1f2cea29f9330e18402b7872f93f5fdf4c136f6b40060a2440536b3656ce7fdb28db9721f92f2f462ff4a99d6efb82d4f08bf58ef1a3425dd015665 SHA512 92b6db2bdf6531a876a93069654448a77fa25e645d669df7144d8a8514d63ef9336cef9bfbd9bbaf7f1ce001b26ca7bdb39b19b7549c2b193ee0292f0522e47c
+DIST zoom-3.5.383291.0407_x86_64.tar.xz 72618832 BLAKE2B e9fa38fae525688f8d9f14a0c2bfe04201edfe2719d075caf9d9de0a2454010b68a6d1df0cd480152641f5763caff7aab1427fee268e3c8239797c792551b709 SHA512 531ce43fdeb4c4df50a85e8a28a90f25d9df7c97b87014fef1e9c94836abbc4d6e76f081b2418c6e538052a2f69e052e0a1ebb9bb0dc33cffffc683bb5b2aef4
diff --git a/net-im/zoom/zoom-3.5.383291.0407.ebuild b/net-im/zoom/zoom-3.5.383291.0407.ebuild
new file mode 100644 (file)
index 0000000..3dccb75
--- /dev/null
@@ -0,0 +1,108 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+DESCRIPTION="Video conferencing and web conferencing service"
+HOMEPAGE="https://zoom.us/"
+SRC_URI="amd64? ( https://zoom.us/client/${PV}/${PN}_x86_64.tar.xz -> ${P}_x86_64.tar.xz )
+       x86? ( https://zoom.us/client/${PV}/${PN}_i686.tar.xz -> ${P}_i686.tar.xz )"
+S="${WORKDIR}/${PN}"
+
+LICENSE="all-rights-reserved Apache-2.0" # Apache-2.0 for icon
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="bundled-libjpeg-turbo pulseaudio"
+RESTRICT="mirror bindist strip"
+
+RDEPEND="!games-engines/zoom
+       dev-libs/glib:2
+       dev-libs/icu
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtdiag:5
+       dev-qt/qtgraphicaleffects:5
+       dev-qt/qtgui:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtquickcontrols:5[widgets]
+       dev-qt/qtscript:5
+       dev-qt/qtsvg:5
+       dev-qt/qtwidgets:5
+       media-sound/mpg123
+       sys-apps/dbus
+       sys-apps/util-linux
+       virtual/opengl
+       x11-libs/libX11
+       x11-libs/libxcb
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXtst
+       x11-libs/xcb-util-image
+       x11-libs/xcb-util-keysyms
+       amd64? (
+               dev-qt/qtdeclarative:5[widgets]
+               dev-qt/qtpositioning:5
+               dev-qt/qtprintsupport:5
+               dev-qt/qtwebchannel:5
+               dev-qt/qtwebengine:5[widgets]
+       )
+       x86? (
+               dev-qt/qtdeclarative:5
+               dev-qt/qtwebkit:5
+       )
+       !bundled-libjpeg-turbo? ( media-libs/libjpeg-turbo )
+       pulseaudio? ( media-sound/pulseaudio )
+       !pulseaudio? ( media-libs/alsa-lib )"
+
+BDEPEND="!pulseaudio? ( dev-util/bbe )"
+
+QA_PREBUILT="opt/zoom/*"
+
+src_prepare() {
+       default
+       if ! use pulseaudio; then
+               # For some strange reason, zoom cannot use any ALSA sound devices if
+               # it finds libpulse. This causes breakage if media-sound/apulse[sdk]
+               # is installed. So, force zoom to ignore libpulse.
+               bbe -e 's/libpulse.so/IgNoRePuLsE/' zoom >zoom.tmp || die
+               mv zoom.tmp zoom || die
+       fi
+}
+
+src_install() {
+       insinto /opt/zoom
+       exeinto /opt/zoom
+       doins -r json sip timezones translations
+       doins *.pcm *.pem *.sh Embedded.properties version.txt
+       use amd64 && doins icudtl.dat
+       doexe zoom{,.sh,linux} zopen ZoomLauncher
+       dosym {"../../usr/$(get_libdir)",/opt/zoom}/libmpg123.so
+
+       if use bundled-libjpeg-turbo; then
+               doexe libturbojpeg.so.0.1.0
+               dosym libturbojpeg.so.0.1.0 /opt/zoom/libturbojpeg.so
+       else
+               dosym {"../../usr/$(get_libdir)",/opt/zoom}/libturbojpeg.so #715106
+       fi
+
+       make_wrapper zoom ./zoom /opt/zoom
+       make_desktop_entry "zoom %U" Zoom zoom-videocam "" \
+               "MimeType=x-scheme-handler/zoommtg;application/x-zoom;"
+       # The tarball doesn't contain an icon, so take a generic camera icon
+       # from https://github.com/google/material-design-icons, modified to be
+       # white on a blue background
+       doicon -s scalable "${FILESDIR}"/zoom-videocam.svg
+       doicon -s 24 "${FILESDIR}"/zoom-videocam.xpm
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+}