# ChangeLog for app-text/xetex
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xetex/ChangeLog,v 1.6 2006/10/30 00:55:21 joslwah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xetex/ChangeLog,v 1.7 2006/10/30 13:56:54 joslwah Exp $
+
+ 30 Oct 2006; Joshua <joslwah@gentoo.org> files/xetex-0.995-install.patch,
+ xetex-0.995.ebuild:
+ Move some hyphen files into site directory to avoid collision with
+ tetex. Removing collisions also requires use of tetex-3.
30 Oct 2006; Joshua <joslwah@gentoo.org> xetex-0.995.ebuild:
Small update to fix collisions with tetex-3.
---- install-xetex 2006-08-23 03:41:00.000000000 +0800
-+++ install-xetex.gentoo 2006-10-28 18:15:12.000000000 +0800
+--- install-xetex 2006-10-30 13:09:09.795732198 +0800
++++ install-xetex.gentoo 2006-10-30 13:09:27.064330965 +0800
@@ -30,9 +30,10 @@
if [ -L ${texbin} ]; then
texbin=`readlink ${texbin}`
if [ "x${texmflocal}" == "x" ]; then
# if --var-value didn't work, try to find the definition in the texmf.cnf file
CNF=`kpsewhich texmf.cnf`
+@@ -74,8 +75,8 @@
+ echo ${texmflocal}/web2c/xetex.pool >> ${filelist}
+
+ # update kpathsearch databases because we've installed a bunch of stuff
+-texhash ${texmflocal}
++#texhash ${texmflocal}
+
+ # this will build the format files on the system where this script is run;
+ # for packaged binary installations, we must repeat this on the target
+-sh ./rebuild-formats
++#sh ./rebuild-formats
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xetex/xetex-0.995.ebuild,v 1.3 2006/10/30 00:55:21 joslwah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xetex/xetex-0.995.ebuild,v 1.4 2006/10/30 13:56:54 joslwah Exp $
inherit eutils
KEYWORDS="~ppc64 ~sparc"
IUSE=""
-RDEPEND="app-text/xdvipdfmx app-text/tetex"
-DEPEND="app-text/tetex"
+RDEPEND="app-text/xdvipdfmx >=app-text/tetex-3.0"
+DEPEND=">=app-text/tetex-3.0"
src_unpack() {
unpack ${A}
# Need to softlink xelatex to xetex.
cd ${D}/usr/bin
ln -s xetex xelatex
+ mkdir -p ${D}usr/share/texmf-site/tex/generic
+ mv ${D}usr/share/texmf/tex/generic/hyphen ${D}usr/share/texmf-site/tex/generic
+
}
pkg_preinst()
{
+ pwd
+ cd ${S}
+ ln -sf ${D}usr/share/texmf-site/tex/generic/hyphen ${D}usr/share/texmf/tex/generic/hyphen
+ texhash "${D}usr/share/texmf"
+ sh ./rebuild-formats
+
+ # And tidy up fmtutil's location.
fmtutil=`kpsewhich --format="web2c files" fmtutil.cnf`
if [ -L $fmtutil ] ; then
fmtutil_real=`readlink "${fmtutil}"`
mkdir -p ${D}`dirname "${fmtutil_real}"`
mv "${D}${fmtutil}" "${D}${fmtutil_real}"
fi
+
+ rm ${D}usr/share/texmf/tex/generic/hyphen
+
}
pkg_postinst()