sci-libs/suitesparseconfig: Add 32bit support
authorJustin Lecher <jlec@gentoo.org>
Sun, 22 Jan 2017 10:08:20 +0000 (10:08 +0000)
committerJustin Lecher <jlec@gentoo.org>
Sun, 22 Jan 2017 10:21:13 +0000 (10:21 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sci-libs/suitesparseconfig/suitesparseconfig-4.2.1-r1.ebuild [new file with mode: 0644]

diff --git a/sci-libs/suitesparseconfig/suitesparseconfig-4.2.1-r1.ebuild b/sci-libs/suitesparseconfig/suitesparseconfig-4.2.1-r1.ebuild
new file mode 100644 (file)
index 0000000..4a79daa
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="Common configurations for all packages in suitesparse"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SuiteSparse_config"
+SRC_URI="https://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" \
+               econf \
+               $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+       if ! use static-libs; then
+               find "${ED}" -name "*.la" -delete || die
+       fi
+}