app-crypt/certbot: fix testing, again
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 6 Feb 2020 22:56:10 +0000 (16:56 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 6 Feb 2020 22:57:11 +0000 (16:57 -0600)
Closes: https://bugs.gentoo.org/708506
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-crypt/certbot/certbot-1.2.0-r1.ebuild [moved from app-crypt/certbot/certbot-1.2.0.ebuild with 84% similarity]
app-crypt/certbot/certbot-9999.ebuild

similarity index 84%
rename from app-crypt/certbot/certbot-1.2.0.ebuild
rename to app-crypt/certbot/certbot-1.2.0-r1.ebuild
index ec673774775d55c4a28f08f515fe6f34b01de655..c81039179f59f69ed281d6551bd2e0a1cc2e2b01 100644 (file)
@@ -38,14 +38,12 @@ RDEPEND="
        dev-python/pytz[${PYTHON_USEDEP}]
        dev-python/zope-component[${PYTHON_USEDEP}]
        dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="
-       ${CDEPEND}
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )"
-
-python_test() {
-       # acme is not installed, removing it here is fine, the dir just confuses tests
-       rm -R ../acme
-       pytest -vv ${PN} || die
+DEPEND="${CDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       # required as deps of deps can trigger this too...
+       echo '    ignore:.*collections\.abc:DeprecationWarning' >> ../pytest.ini
+       distutils-r1_python_prepare_all
 }
index ec673774775d55c4a28f08f515fe6f34b01de655..c81039179f59f69ed281d6551bd2e0a1cc2e2b01 100644 (file)
@@ -38,14 +38,12 @@ RDEPEND="
        dev-python/pytz[${PYTHON_USEDEP}]
        dev-python/zope-component[${PYTHON_USEDEP}]
        dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="
-       ${CDEPEND}
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )"
-
-python_test() {
-       # acme is not installed, removing it here is fine, the dir just confuses tests
-       rm -R ../acme
-       pytest -vv ${PN} || die
+DEPEND="${CDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       # required as deps of deps can trigger this too...
+       echo '    ignore:.*collections\.abc:DeprecationWarning' >> ../pytest.ini
+       distutils-r1_python_prepare_all
 }