www-servers/nginx-unit: upstream release 1.10.0
authorRalph Seichter <github@seichter.de>
Thu, 22 Aug 2019 20:59:11 +0000 (22:59 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 25 Aug 2019 11:37:34 +0000 (14:37 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Ralph Seichter <gentoo@seichter.de>
Closes: https://github.com/gentoo/gentoo/pull/12768
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
www-servers/nginx-unit/Manifest
www-servers/nginx-unit/nginx-unit-1.10.0.ebuild [new file with mode: 0644]

index 0fa251df271e8baac39ec70546932d436ad6801a..fcbfded696a994f79373f4c79608ac35706edaf2 100644 (file)
@@ -1,2 +1,3 @@
+DIST nginx-unit-1.10.0.tar.gz 564348 BLAKE2B 82339422b4b3b696ff4bbb216d6c0d54f046531aa56f6e0f5602a9bbe18db878b6bc9c9e9b1513be0cee3197f288549d8a6f826bf69ffbb91fc35757775bde4d SHA512 da2b248ba22e5d46fa1c8c21041a875655fad0e1a09683c58cb5bb33ed0a671a921c7a13f99269f0574da02d0efaeff0233abc901e4e333f3f7ac9383334c781
 DIST nginx-unit-1.8.0.tar.gz 511226 BLAKE2B e396b27954840a5f1ad3a4cd9501a5e5fe769a754c51043da784a2c4596e6acc33089f495bf412a0db086e5c715a51292c7dece004a6512564421a431b6c339e SHA512 1d0ad05343ff70aff4c6e221a36c20df95fa2e2262ae5c69963a9bcb9ef883151e8a2fa9fef29f43ac5489aa5cbb3e9dfd10cf5e7f6d7a98742b490ebf3a0413
 DIST nginx-unit-1.9.0.tar.gz 522420 BLAKE2B 8fabd8a43c8e5b07a8d9db41bb1d9790a6d434a20b762649557bc4e715a00b663416cd9556c9e5fc1894487172c1549de4d5511259876ea6bcd306e258e0ff5f SHA512 25beda88e3e92cace7acfee45a640c351f4e15f20f2aa0f047c3ba61351c6119f270754186f39ab3f1fcc16b1bef9009da4f507d5cdf511538825f2a4c879d62
diff --git a/www-servers/nginx-unit/nginx-unit-1.10.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.10.0.ebuild
new file mode 100644 (file)
index 0000000..72e543d
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python2_7 python3_{5,6,7})
+
+inherit python-single-r1
+
+MY_P="unit-${PV}"
+DESCRIPTION="A dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php5-6 php7-1 php7-2 php7-3"
+IUSE="${MY_USE} ${MY_USE_PHP}"
+REQUIRED_USE="|| ( ${IUSE} )
+       python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+       php5-6? ( dev-lang/php:5.6[embed] )
+       php7-1? ( dev-lang/php:7.1[embed] )
+       php7-2? ( dev-lang/php:7.2[embed] )
+       php7-3? ( dev-lang/php:7.3[embed] )
+       python? ( ${PYTHON_DEPS} )
+       ruby? ( dev-lang/ruby:= )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+       ./configure \
+               --control=unix:/run/${PN}.sock \
+               --ld-opt="${LDFLAGS}" \
+               --log=/var/log/${PN} \
+               --modules=$(get_libdir)/${PN} \
+               --pid=/run/${PN}.pid \
+               --prefix=/usr \
+               --state=/var/lib/${PN} || die "Core configuration failed"
+       for flag in ${MY_USE} ; do
+               if use ${flag} ; then
+                       ./configure ${flag} || die "Module configuration failed: ${flag}"
+               fi
+       done
+       for flag in ${MY_USE_PHP} ; do
+               if use ${flag} ; then
+                       local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+                       ./configure php \
+                               --module=${flag} \
+                               --config=${php_slot}/bin/php-config \
+                               --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+               fi
+       done
+}
+
+src_install() {
+       default
+       diropts -m 0770
+       keepdir /var/lib/${PN}
+       newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}