app-emulation/diskimage-builder: 2.24.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 19 Jun 2019 14:52:42 +0000 (09:52 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 19 Jun 2019 14:53:01 +0000 (09:53 -0500)
Package-Manager: Portage-2.3.66, Repoman-2.3.14
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-emulation/diskimage-builder/Manifest
app-emulation/diskimage-builder/diskimage-builder-2.24.0.ebuild [new file with mode: 0644]

index 5b6a35c2f2d2c0754cea8990998689a85f9a0b7e..c7ea608b636271686dd6d64084a8f0ffa56766bf 100644 (file)
@@ -1 +1,2 @@
 DIST diskimage-builder-2.23.0.tar.gz 403817 BLAKE2B 14b67dc456bd9dab13a534f0f6df27b8a74514966ad965b401d33274d37ee2f201fa1dcd64b2c04a7503ab1f6a893dc40b5145c9559a7be74a029e2da226758a SHA512 89b2ee7eda56c610b9c343edd51276d54eb129ce319cf7f0fdebbccd1bba52903d16a71f1558bb76d2011d5267ffbc62bde94f5d7fd5aabdab2bc82abf10c685
+DIST diskimage-builder-2.24.0.tar.gz 408702 BLAKE2B 069083aef6214d59d9731a13691c2b48cb354085b698c8f711b3cd93c54d44acb08487510b2b9b038a53c533ea17f41b2521c36eee643c09dc409ea13c21fa6b SHA512 90bf13059f9310f3b45bf7c1a550d837e4d73920efa2af2ae30ec3cd5118d3db223b6953d5209ef0f7029c23f17772de1a36cfba87d7e86bbe8a481aa4ee0639
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.24.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.24.0.ebuild
new file mode 100644 (file)
index 0000000..86d3bb1
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+       <dev-python/networkx-2.3[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+       >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+       <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+       app-emulation/qemu
+       sys-block/parted
+       sys-fs/multipath-tools
+       sys-fs/dosfstools
+       sys-apps/gptfdisk
+       !dev-python/dib-utils[${PYTHON_USEDEP}]"