Version bump (Bug 385479)
authorOle Markus With <olemarkus@gentoo.org>
Sat, 15 Oct 2011 10:21:44 +0000 (10:21 +0000)
committerOle Markus With <olemarkus@gentoo.org>
Sat, 15 Oct 2011 10:21:44 +0000 (10:21 +0000)
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64

dev-php/PEAR-DB_DataObject/ChangeLog
dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.9.6.ebuild [new file with mode: 0644]

index f07eb79fe074cda887f39d83553fe6e6581c8233..35e730435c7e8162fb082ef63884c59e74b91f4d 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-php/PEAR-DB_DataObject
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-DB_DataObject/ChangeLog,v 1.38 2010/02/16 04:30:09 beandog Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-DB_DataObject/ChangeLog,v 1.39 2011/10/15 10:21:44 olemarkus Exp $
+
+*PEAR-DB_DataObject-1.9.6 (15 Oct 2011)
+
+  15 Oct 2011; Ole Markus With <olemarkus@gentoo.org>
+  +PEAR-DB_DataObject-1.9.6.ebuild:
+  Version bump (Bug 385479)
 
 *PEAR-DB_DataObject-1.9.3 (16 Feb 2010)
 
diff --git a/dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.9.6.ebuild b/dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.9.6.ebuild
new file mode 100644 (file)
index 0000000..c4a9915
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.9.6.ebuild,v 1.1 2011/10/15 10:21:44 olemarkus Exp $
+
+EAPI="4"
+
+inherit php-pear-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="A SQL Builder, Object Interface to Database Tables"
+LICENSE="PHP-2.02 PHP-3"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND=""
+RDEPEND=">=dev-php/PEAR-DB-1.7.6-r1
+       >=dev-php/PEAR-Date-1.4.3-r1
+       !minimal? ( >=dev-php/PEAR-Validate-0.5.0-r1
+                   >=dev-php/PEAR-MDB2-2.0.0_rc1 )"
+
+src_unpack() {
+       unpack "${A}"
+       # don't install windows-only stuff
+       sed -re 's:<file baseinstalldir="DB" md5sum=".{32}" name="scripts/DB_DataObject_createTables.bat" role="script" />::' -i package.xml || die "sed failed"
+}