www-apps/baikal: version bump to v0.6.0
authorFabian Groffen <grobian@gentoo.org>
Sun, 20 Oct 2019 11:07:34 +0000 (13:07 +0200)
committerFabian Groffen <grobian@gentoo.org>
Sun, 20 Oct 2019 11:07:50 +0000 (13:07 +0200)
Closes: https://bugs.gentoo.org/695974
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
www-apps/baikal/Manifest
www-apps/baikal/baikal-0.6.0.ebuild [new file with mode: 0644]

index 1429520dd254a3cb9f165f0a24e085691d3fe848..537e3c0d0ccaf5f0d2254dbb7c5e63c7980b2abf 100644 (file)
@@ -1,2 +1,3 @@
 DIST baikal-0.4.6.zip 3288478 BLAKE2B e841c405e59808411999475431e79945a00f2de33228d6a46812acca03b742c1c23349c59d6501b0a1b39587030047682fbc92ead54565766f81a19ee76efdc0 SHA512 8cb4141deb4233858764e6bd0eb44691c5e31677dd6dde09e8249675a331115af8bbcf181c4371338165a0ef40f894dfc4ed0502b46a6bc8387924f6a65725a1
 DIST baikal-0.5.2.zip 3426025 BLAKE2B ac13b42a3eab54e43761bd0ad958208b692919a61908a6467e710a045c6568e9ae616a54c6910b6828c4499b3f815bd96b9bee12608637b64182238725e21922 SHA512 58dd9e231840a76582a70abca89c8f73f1a26f06855eff6949ebca526a22d23bc06f281f51611aeb7f0cf8334c0ad490cfea962905e985d6c75e78e1c1d47e63
+DIST baikal-0.6.0.zip 3432758 BLAKE2B db55008e2e971fd8d6edabe38f333c32564ef34cf7f3a93ad9d67083646c9575cdf9ba1d51108c5fe9f5d385a53bd78d1406318f3a72672126b5f31cc032b104 SHA512 75cd3e30c3df4bc5057e14215b320647c9683702171671ed58ac83e12f7770454d81970f036fd96dbb9aefe0928fcf40ae11128687fd261a0dccadf15d148905
diff --git a/www-apps/baikal/baikal-0.6.0.ebuild b/www-apps/baikal/baikal-0.6.0.ebuild
new file mode 100644 (file)
index 0000000..798bd52
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit webapp
+
+DESCRIPTION="Lightweight CalDAV+CardDAV server"
+HOMEPAGE="http://sabre.io/baikal/"
+SRC_URI="https://github.com/sabre-io/Baikal/releases/download/${PV}/${P}.zip"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~ppc64"
+IUSE="+mysql sqlite"
+REQUIRED_USE="|| ( mysql sqlite )"
+
+RDEPEND=">=dev-lang/php-6[ctype,filter,json,pdo,session,xml,xmlreader,xmlwriter,mysql?,sqlite?]
+       mysql? ( virtual/mysql )
+       sqlite? ( dev-db/sqlite )
+       virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+       webapp_src_preinst
+
+       dodoc *.md  || die "dodoc failed"
+
+       einfo "Installing web files"
+       insinto "${MY_HTDOCSDIR}"
+       doins -r html/* html/.htaccess Core vendor || die "doins failed"
+
+       einfo "Setting up container for configuration"
+       insinto /etc/${PN}
+
+       einfo "Fixing symlinks"
+       local link target
+       find "${D}${MY_HTDOCSDIR}" -type l | while read link ; do
+               target=$(readlink "${link}")
+               target=${target/..\/Core/Core}
+               rm "${link}" && ln -s "${target}" "${link}"
+       done
+       dosym /etc/${PN} "${MY_HTDOCSDIR}"/Specific
+       dosym . "${MY_HTDOCSDIR}"/html
+
+       webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+       webapp_src_install
+
+       if has_version www-servers/apache ; then
+               fowners -R apache:apache /etc/${PN}
+       elif has_version www-servers/nginx ; then
+               fowners -R nginx:nginx /etc/${PN}
+       else
+               einfo "/etc/${PN} must be owned by the webserver user for baikal"
+       fi
+}