media-tv/kodi: run the codegenerator when USE=java #558798
authorMike Frysinger <vapier@gentoo.org>
Sat, 19 Sep 2015 02:30:08 +0000 (22:30 -0400)
committerMike Frysinger <vapier@gentoo.org>
Sat, 19 Sep 2015 06:24:46 +0000 (02:24 -0400)
Since we don't include the precompiled generated files when USE=java,
make sure we explicitly run the bootstrap step since the build doesn't
handle it for us.

media-tv/kodi/kodi-15.1.ebuild
media-tv/kodi/kodi-9999.ebuild

index f8a9d2a12f5fd47f16aea99d5affd299f7d23b4f..912c5e5822e2d34bf4b4d69ff0f0671bcb892fb2 100644 (file)
@@ -9,7 +9,7 @@ EAPI="5"
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="sqlite"
 
-inherit eutils linux-info python-single-r1 multiprocessing autotools
+inherit eutils linux-info python-single-r1 multiprocessing autotools toolchain-funcs
 
 CODENAME="Isengard"
 case ${PV} in
@@ -172,7 +172,9 @@ src_prepare() {
        multijob_finish
        elibtoolize
 
-       [[ ${PV} == "9999" ]] && emake -f codegenerator.mk
+       if [[ ${PV} == "9999" ]] || use java ; then #558798
+               tc-env_build emake -f codegenerator.mk
+       fi
 
        # Disable internal func checks as our USE/DEPEND
        # stuff handles this just fine already #408395
index 5c7905dec143176d220d5d35ae72b3ca940275ab..165dacba6b061a1b8107f66eacd5878bcfb08a41 100644 (file)
@@ -9,7 +9,7 @@ EAPI="5"
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="sqlite"
 
-inherit eutils linux-info python-single-r1 multiprocessing autotools
+inherit eutils linux-info python-single-r1 multiprocessing autotools toolchain-funcs
 
 CODENAME="Isengard"
 case ${PV} in
@@ -172,7 +172,9 @@ src_prepare() {
        multijob_finish
        elibtoolize
 
-       [[ ${PV} == "9999" ]] && emake -f codegenerator.mk
+       if [[ ${PV} == "9999" ]] || use java ; then #558798
+               tc-env_build emake -f codegenerator.mk
+       fi
 
        # Disable internal func checks as our USE/DEPEND
        # stuff handles this just fine already #408395