media-libs/libmng: don't call 'gcc' in src_prepare(), bug #720884
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 25 May 2020 08:37:05 +0000 (09:37 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 25 May 2020 08:37:27 +0000 (09:37 +0100)
Before the change src_prepare() was calling 'emake distclean'.
That forced reconfiguration with default CC=gcc.

The change just deletes files which 'make distclean' would delete.

Reported-by: Agostino Sarubbo
Closes: https://bugs.gentoo.org/720884
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
media-libs/libmng/libmng-2.0.3.ebuild

index d894ab2fc5f5c83efa3ad615f79584b737c51204..766e9a921b3d492b57511946b0d94adb9eca8923 100644 (file)
@@ -23,9 +23,10 @@ DEPEND="${RDEPEND}"
 PATCHES=( "${FILESDIR}"/${P}-jpeg-9a.patch )
 
 src_prepare() {
-       eautoreconf
-       emake distclean
        default
+       # effect of 'make distclean'
+       rm Makefile config.h config.log config.status libmng.pc stamp-h1 || die
+       eautoreconf
 }
 
 multilib_src_configure() {