sys-cluster/teleport: update teleport-9999.ebuild
authorGraeme Lawes <graemelawes@gmail.com>
Fri, 11 Oct 2019 03:22:44 +0000 (23:22 -0400)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 11 Oct 2019 13:48:03 +0000 (16:48 +0300)
* Use EAPI 7
* Update LICENSE
* zip is a BDEPEND

Signed-off-by: Graeme Lawes <graemelawes@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12744
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-cluster/teleport/teleport-9999.ebuild

index e68586870d20e63f1cea7257dc52a8d5d4c72d5e..a82f2fc86c9259e851160dea5d12e3e992bb34b3 100644 (file)
@@ -1,7 +1,8 @@
 # Copyright 2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
+
 inherit golang-build systemd
 
 DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
@@ -19,11 +20,11 @@ else
 fi
 
 IUSE="pam"
-LICENSE="Apache-2.0"
+LICENSE="Apache-2.0 MIT BSD ISC"
 RESTRICT="test strip"
 SLOT="0"
 
-DEPEND="app-arch/zip"
+BDEPEND="app-arch/zip"
 RDEPEND="pam? ( sys-libs/pam )"
 
 src_compile() {