dev-python/pyicu: Force C++11
authorDavid Seifert <soap@gentoo.org>
Sat, 26 May 2018 12:21:34 +0000 (14:21 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 26 May 2018 12:22:39 +0000 (14:22 +0200)
Closes: https://bugs.gentoo.org/651748
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/pyicu/pyicu-2.0.3.ebuild

index 4dc247fee2d4becb148a18fca148079a19759922..37fb2ef11b9742164227046b8cd36863799a246a 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 
 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
 
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
 
 MY_PN="PyICU"
 MY_P="${MY_PN}-${PV}"
@@ -30,6 +30,14 @@ S="${WORKDIR}/${MY_P}"
 
 DOCS=(CHANGES CREDITS README.md)
 
+python_prepare_all() {
+       # bug 651748
+       # due to ICU 59 requiring C++11 now
+       append-cxxflags -std=c++11
+
+       distutils-r1_python_prepare_all
+}
+
 python_test() {
        if [[ ${EPYTHON} == python2* ]]; then
                # See Bug #644226