gnome-extra/gnome-shell-extensions-topicons-plus: Bump to v27
authorPacho Ramos <pacho@gentoo.org>
Thu, 30 Apr 2020 18:16:57 +0000 (20:16 +0200)
committerPacho Ramos <pacho@gentoo.org>
Thu, 30 Apr 2020 18:17:09 +0000 (20:17 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
gnome-extra/gnome-shell-extensions-topicons-plus/Manifest
gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-27.ebuild [new file with mode: 0644]

index 195f9204a7fe6ee89ead878146ff820b87c1ef63..fd2ba0ff5b3e574b2013f8a9d38a3c4cf99a6b96 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-shell-extensions-topicons-plus-22_p20190929.tar.gz 2759460 BLAKE2B 2eb001f472395ade58503a860d3ea8248bb8aeb36b4d6f13f65e1074694aecc02f814d18d449206e1055984177896ac787fd925b4cf2680f226ffaace042cc5d SHA512 47cb156f7a61780a53311855d716c4e4f539832080fc011db634b472b5a8aa0e9fad5b6f44bf2da30665cd97b850725822ee9fb9ed9da014388cf4adeee60fbe
+DIST gnome-shell-extensions-topicons-plus-27.tar.gz 2759687 BLAKE2B 854e5c8c1f749bdb3d8b83ac98d39ddcf22cfbe7221601a80b7b961c1d0dbe8ee2242ec5378c409c786957ff47602a7828fca55a09e7fa6225d4477a156a61de SHA512 3df28397bcefda7a43e6eaa520629f08a3538c98675243af2b1e109ec913d70b55f142169ad0035d0d29cacdf8f2c908eedf222e852591ed1dd5b6aa6b34591e
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-27.ebuild b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-27.ebuild
new file mode 100644 (file)
index 0000000..e4e9c84
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Moves legacy tray icons to top panel"
+HOMEPAGE="https://extensions.gnome.org/extension/1031/topicons/"
+SRC_URI="https://github.com/phocean/TopIcons-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/TopIcons-plus-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+DEPEND="
+       dev-libs/glib:2
+"
+RDEPEND="${DEPEND}
+       app-eselect/eselect-gnome-shell-extensions
+       >=gnome-base/gnome-shell-3.34
+"
+BDEPEND=""
+
+src_install() {
+       # TODO: Figure out if we can get the schemas to standard location, in a way that works properly runtime too
+       make install INSTALL_PATH="${ED}/usr/share/gnome-shell/extensions/"
+       rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/README.md" || die
+       # Assuming it needs only compiled gettext catalogs at runtime
+       rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/locale"/*/LC_MESSAGES/*.po || die
+       dodoc README.md
+}
+
+pkg_postinst() {
+       ebegin "Updating list of installed extensions"
+       eselect gnome-shell-extensions update
+       eend $?
+}