app-office/calligra: Avoid dep on poppler[glib] for ifdef
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 24 Jan 2019 22:57:21 +0000 (23:57 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 24 Jan 2019 22:59:33 +0000 (23:59 +0100)
Closes: https://bugs.gentoo.org/675972
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-office/calligra/calligra-3.1.0-r3.ebuild
app-office/calligra/files/calligra-3.1.0-poppler-0.72.patch

index c3913bd48d1ca2084337604a195a54d2c4326693..81597b0d7d197600a7d33453128091818f3f972e 100644 (file)
@@ -104,7 +104,6 @@ COMMON_DEPEND="
 DEPEND="${COMMON_DEPEND}
        dev-libs/boost
        sys-devel/gettext
-       x11-misc/shared-mime-info
        test? ( $(add_frameworks_dep threadweaver) )
 "
 RDEPEND="${COMMON_DEPEND}
@@ -121,8 +120,6 @@ PATCHES=(
        "${FILESDIR}"/${P}-stage-qt-5.11.patch
        "${FILESDIR}"/${P}-poppler-0.69.patch
        "${FILESDIR}"/${P}-poppler-0.71.patch
-       "${FILESDIR}"/${P}-poppler-0.72.patch # not upstreamable
-       "${FILESDIR}"/${P}-poppler-0.73.patch
        "${FILESDIR}"/${P}-no-webkit.patch
 )
 
@@ -138,6 +135,11 @@ pkg_setup() {
 src_prepare() {
        kde5_src_prepare
 
+       if has_version ">=app-text/poppler-0.72"; then
+               eapply "${FILESDIR}"/${P}-poppler-0.72.patch # not upstreamable
+               eapply "${FILESDIR}"/${P}-poppler-0.73.patch
+       fi
+
        if ! use test; then
                sed -e "/add_subdirectory( *benchmarks *)/s/^/#DONT/" \
                        -i libs/pigment/CMakeLists.txt || die
index 3b2e690257be55444171c01f6bdc9975da8a18da..817a8ddcd679249892497a28dc622d1763c294b6 100644 (file)
@@ -1,54 +1,39 @@
-From 8f20ea906235cbee1d4aac4706e4eb03366875bf Mon Sep 17 00:00:00 2001
-From: "Tobias C. Berner" <tcberner@FreeBSD.org>
-Date: Mon, 7 Jan 2019 19:50:48 +0100
-Subject: [PATCH] Make compatible with poppler 0.72
+From 3784fdf0259a14f1f7b20c156dcfe42b45d76896 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 24 Jan 2019 23:55:02 +0100
+Subject: [PATCH] Fix build with poppler-0.72
 
+This is a downstream fix without backwards compat, not upstreamable.
 ---
- filters/karbon/pdf/SvgOutputDev.cpp | 13 +++++++++++++
- 1 file changed, 13 insertions(+)
+ filters/karbon/pdf/SvgOutputDev.cpp | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
 
 diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
-index 4a1fad6bbcf..b1d4ea2d427 100644
+index 391e86cc117..bc72a003efb 100644
 --- a/filters/karbon/pdf/SvgOutputDev.cpp
 +++ b/filters/karbon/pdf/SvgOutputDev.cpp
-@@ -25,6 +25,7 @@
- #include <poppler/GfxState.h>
- #include <poppler/Stream.h>
- #include <poppler/GfxFont.h>
-+#include <poppler/glib/poppler-features.h>
- #include <QFile>
- #include <QTextStream>
-@@ -409,7 +410,11 @@ void SvgOutputDev::drawString(GfxState * state, const GooString * s)
+@@ -402,7 +402,7 @@ void SvgOutputDev::drawString(GfxState * state, const GooString * s)
  
      QString str;
  
-+#if POPPLER_CHECK_VERSION(0,72,0)
+-    const char * p = s->getCString();
 +    const char * p = s->c_str();
-+#else
-     const char * p = s->getCString();
-+#endif
      int len = s->getLength();
      CharCode code;
      Unicode *u = nullptr;
-@@ -459,10 +464,18 @@ void SvgOutputDev::drawString(GfxState * state, const GooString * s)
+@@ -451,10 +451,10 @@ void SvgOutputDev::drawString(GfxState * state, const GooString * s)
      *d->body << " y=\"" << y << "px\"";
  
      if (font && font->getFamily()) {
-+#if POPPLER_CHECK_VERSION(0,72,0)
+-        *d->body << " font-family=\"" << QString::fromLatin1(font->getFamily()->getCString()) << "\"";
 +        *d->body << " font-family=\"" << QString::fromLatin1(font->getFamily()->c_str()) << "\"";
-+#else
-         *d->body << " font-family=\"" << QString::fromLatin1(font->getFamily()->getCString()) << "\"";
-+#endif
          //debugPdf << "font family:" << QString::fromLatin1( font->getFamily()->getCString() );
      } else if (font && font->getName()) {
-+#if POPPLER_CHECK_VERSION(0,72,0)
+-        *d->body << " font-family=\"" << QString::fromLatin1(font->getName()->getCString()) << "\"";
 +        *d->body << " font-family=\"" << QString::fromLatin1(font->getName()->c_str()) << "\"";
-+#else
-         *d->body << " font-family=\"" << QString::fromLatin1(font->getName()->getCString()) << "\"";
-+#endif
          //debugPdf << "font name:" << QString::fromLatin1( font->getName()->getCString() );
      }
      *d->body << " font-size=\"" << qMax(state->getFontSize(), state->getTransformedFontSize()) << "px\"";
 -- 
 2.20.1
+