dev-python/pelican-minify: adding
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 21 Oct 2017 18:40:36 +0000 (13:40 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 21 Oct 2017 18:40:58 +0000 (13:40 -0500)
Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-python/pelican-minify/Manifest [new file with mode: 0644]
dev-python/pelican-minify/metadata.xml [new file with mode: 0644]
dev-python/pelican-minify/pelican-minify-0.9.ebuild [new file with mode: 0644]

diff --git a/dev-python/pelican-minify/Manifest b/dev-python/pelican-minify/Manifest
new file mode 100644 (file)
index 0000000..3591190
--- /dev/null
@@ -0,0 +1 @@
+DIST pelican-minify-0.9.tar.gz 223517 SHA256 a0ffa9b1f15089bc4aec4692c5feba87356d427a7946ffd8b6222ac4c7758773 SHA512 de28727ed6b39e89461b2d725139b88010def892f3fd23f822a6e84a585b3f93771fdc9ca8f402adc9bb196a0dde03b9d6417317c7e8141d83f0e6460860cd33 WHIRLPOOL 89ac8d6537bf2df3a1cdc1891c97c0e0a14299c99256ab2680d8f20fd56070c58b0455434d39116749c59fbf0e96d3a914b553ee98037fdcdf6ea9923d21aa30
diff --git a/dev-python/pelican-minify/metadata.xml b/dev-python/pelican-minify/metadata.xml
new file mode 100644 (file)
index 0000000..29e5ec2
--- /dev/null
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+       </maintainer>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <longdescription lang="en">
+               An HTML minification plugin for Pelican, the static site generator.
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pelican-minify/pelican-minify-0.9.ebuild b/dev-python/pelican-minify/pelican-minify-0.9.ebuild
new file mode 100644 (file)
index 0000000..f1e901f
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="An HTML minification plugin for Pelican, the static site generator."
+HOMEPAGE="https://pypi.python.org/pypi/pelican-minify"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+       >=dev-python/joblib-0.9[${PYTHON_USEDEP}]
+       >=app-text/htmlmin-0.1.5[${PYTHON_USEDEP}]
+       >=app-text/pelican-3.1.1[${PYTHON_USEDEP}]"