net-analyzer/icinga2: update boost dep to depend on context flag
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 22 Sep 2019 06:05:37 +0000 (01:05 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 22 Sep 2019 06:07:52 +0000 (01:07 -0500)
Package-Manager: Portage-2.3.69, Repoman-2.3.17
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
net-analyzer/icinga2/icinga2-2.11.0.ebuild
net-analyzer/icinga2/icinga2-9999.ebuild

index 3ec54860fd1f24fc00e17bcb44cca1c811fd575a..238cca62c36f8a621923641f8afb344085c3aa5b 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 if [[ ${PV} != 9999 ]]; then
        inherit cmake-utils depend.apache eutils systemd toolchain-funcs user wxwidgets
        SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+       KEYWORDS="~amd64 ~arm64 ~x86"
 else
        inherit cmake-utils depend.apache eutils git-r3 systemd toolchain-funcs user wxwidgets
        EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
@@ -23,7 +23,8 @@ WX_GTK_VER="3.0"
 CDEPEND="
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:0= )
-       >=dev-libs/boost-1.66:=
+       >=dev-libs/boost-1.66.0:=[context]
+       <dev-libs/boost-1.71.0
        console? ( dev-libs/libedit )
        mariadb? ( dev-db/mariadb-connector-c:= )
        mysql? ( dev-db/mysql-connector-c:= )
index 3ec54860fd1f24fc00e17bcb44cca1c811fd575a..31e997e9e6a5c2fd8d41fc2fb6ceac2a450fcadd 100644 (file)
@@ -23,7 +23,7 @@ WX_GTK_VER="3.0"
 CDEPEND="
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:0= )
-       >=dev-libs/boost-1.66:=
+       >=dev-libs/boost-1.66:=[context]
        console? ( dev-libs/libedit )
        mariadb? ( dev-db/mariadb-connector-c:= )
        mysql? ( dev-db/mysql-connector-c:= )