dev-python/mox3: PYTHON_COMPAT: add python3_6
authorZac Medico <zmedico@gentoo.org>
Thu, 16 Feb 2017 08:14:18 +0000 (00:14 -0800)
committerZac Medico <zmedico@gentoo.org>
Thu, 16 Feb 2017 09:06:10 +0000 (01:06 -0800)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/mox3/files/mox3-0.12.0-RegexTest-python3.6.patch [new file with mode: 0644]
dev-python/mox3/mox3-0.10.0.ebuild
dev-python/mox3/mox3-0.12.0.ebuild

diff --git a/dev-python/mox3/files/mox3-0.12.0-RegexTest-python3.6.patch b/dev-python/mox3/files/mox3-0.12.0-RegexTest-python3.6.patch
new file mode 100644 (file)
index 0000000..8c118e6
--- /dev/null
@@ -0,0 +1,18 @@
+From: Zac Medico <zmedico@gentoo.org>
+Subject: [PATCH] RegexTest: python3.6 compatibility
+
+https://bugs.launchpad.net/python-mox3/+bug/1665266
+
+--- mox3-0.12.0/mox3/tests/test_mox.py
++++ mox3-0.12.0/mox3/tests/test_mox.py
+@@ -316,8 +316,8 @@
+     def testReprWithFlags(self):
+         """repr should return the regular expression pattern and flags."""
+-        self.assertTrue(repr(mox.Regex(r"a\s+b", flags=4)) ==
+-                        "<regular expression 'a\s+b', flags=4>")
++        self.assertTrue(repr(mox.Regex(r"a\s+b", flags=8)) ==
++                        r"<regular expression 'a\s+b', flags=8>")
+ class IsTest(testtools.TestCase):
index 5404e3405eaf312b8c2b379613c99ba90ad56118..15856263acdd9a778be34f98a3d27028e8872770 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
 DISTUTILS_IN_SOURCE_BUILD=TRUE
 
 inherit distutils-r1
index 2ceca6dc06eab63bd23731f108339434eb433fa2..c412788fc12d27500067a95a85b4bdf0ae25457e 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
 
 inherit distutils-r1
 
@@ -40,6 +40,8 @@ RDEPEND="
        ${CRDEPEND}
 "
 
+PATCHES=( "${FILESDIR}"/${P}-RegexTest-python3.6.patch )
+
 python_compile_all() {
        use doc && esetup.py build_sphinx
 }