net-firewall/nftables-0.9.4-r{1,2}: Fix USE=-python (bug #717162)
authorPatrick McLean <chutzpah@gentoo.org>
Mon, 13 Apr 2020 18:45:46 +0000 (11:45 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Mon, 13 Apr 2020 18:47:12 +0000 (11:47 -0700)
Closes: https://bugs.gentoo.org/717162
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
net-firewall/nftables/nftables-0.9.4-r1.ebuild
net-firewall/nftables/nftables-0.9.4-r2.ebuild

index c6c7496044cf3b472163487878f88976d8aa6448..9cd3da3f64c27e26106208eef07467d8374eb431 100644 (file)
@@ -115,9 +115,9 @@ src_install() {
 
        if use python ; then
                python_foreach_impl python_make install
+               python_foreach_impl python_optimize
        fi
 
-       python_foreach_impl python_optimize
        find "${ED}" -type f -name "*.la" -delete || die
 }
 
index f9a434586f778a7928d2bd027406ddb4021f5bed..cf8385c7c2b56f76a24aff3e76fd3443cc770eab 100644 (file)
@@ -126,9 +126,9 @@ src_install() {
 
        if use python ; then
                python_foreach_impl python_make install
+               python_foreach_impl python_optimize
        fi
 
-       python_foreach_impl python_optimize
        find "${ED}" -type f -name "*.la" -delete || die
 }