dev-python/python-systemd: Bump to 234, py3.7, EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Thu, 18 Jul 2019 09:13:54 +0000 (11:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 18 Jul 2019 09:16:51 +0000 (11:16 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-systemd/Manifest
dev-python/python-systemd/python-systemd-234.ebuild [new file with mode: 0644]

index fda9da3b38a5aa67c642e2d833aae9cffb9f1a74..363ee67f4834b705760308684f51ecbb66c2a91e 100644 (file)
@@ -1 +1,2 @@
 DIST python-systemd-233.tar.gz 49680 BLAKE2B 7d612022738d3114a39f7ad7f4d7799ac3d027980592a5205247d4c866ac3d9520d63ee02f143e26865f0d83338f30422dd0c2299f575e8b03f3112900e9af73 SHA512 92a6cc7123db586e5ae5fbb56e5065b17be9da47ced9dbc5920d80b7db7f56d15b127e72d30889c5b24b119724a33f68be1ef322529620ed95b0f95707e4c2ab
+DIST python-systemd-234.tar.gz 53900 BLAKE2B 2658ee7083036ed8259e5f4ad0714ea15227ee836ad34c7fbbdb55dd9df48751b8d9998350d789b4f47e78fe7b4a7134e12d637e5a6ebeb29a0b31e5a4575d91 SHA512 164e34ba46827711e9c6ff9ed58b2706d9a22abfc7001de030ed7d463d8ddf783eb5fee93b207c29950a3c566018cc3f1a21a549421cf3e05c1287b433367eb2
diff --git a/dev-python/python-systemd/python-systemd-234.ebuild b/dev-python/python-systemd/python-systemd-234.ebuild
new file mode 100644 (file)
index 0000000..978b842
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for native access to the systemd facilities"
+HOMEPAGE="https://github.com/systemd/python-systemd"
+SRC_URI="https://github.com/systemd/python-systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+       sys-apps/systemd:0=
+"
+DEPEND="${COMMON_DEPEND}
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+       !sys-apps/systemd[python(-)]
+"
+
+PATCHES=(
+#      "${FILESDIR}"/233-xfail-bind.patch
+)
+
+python_test() {
+       pushd "${BUILD_DIR}/lib" > /dev/null || die
+       pytest -o cache_dir="${T}" -vv || die
+       popd > /dev/null || die
+}