ros-meta/navigation: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 30 Sep 2015 12:03:37 +0000 (14:03 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 30 Sep 2015 12:03:50 +0000 (14:03 +0200)
Package-Manager: portage-2.2.22

ros-meta/navigation/Manifest [new file with mode: 0644]
ros-meta/navigation/metadata.xml [new file with mode: 0644]
ros-meta/navigation/navigation-1.13.0.ebuild [new file with mode: 0644]
ros-meta/navigation/navigation-9999.ebuild [new file with mode: 0644]

diff --git a/ros-meta/navigation/Manifest b/ros-meta/navigation/Manifest
new file mode 100644 (file)
index 0000000..2ab0c74
--- /dev/null
@@ -0,0 +1 @@
+DIST navigation-1.13.0.tar.gz 336419 SHA256 5ef288325a0de4accfb4ef0cc37d9e9c4106a05d98b0ae5757f6c4823abada97 SHA512 1b686d4d1e930901dcf899fb73c8609855c3bb6d797322f6f3b9ea7ccb349f98802870b44e0fcbee4e68abebeecbaff57d453dc790fbc908cd23b8afda22e1af WHIRLPOOL 096103d8b774205995a12d294c820187fb89302285b363f6e6b9a4bb1e30a2edf9b33a451effc00b8aeec4d8f40664f61266314d389b9c668c0d7cf2152f70dd
diff --git a/ros-meta/navigation/metadata.xml b/ros-meta/navigation/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/ros-meta/navigation/navigation-1.13.0.ebuild b/ros-meta/navigation/navigation-1.13.0.ebuild
new file mode 100644 (file)
index 0000000..483b54d
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="2D navigation stack"
+LICENSE="BSD LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/amcl
+       dev-ros/base_local_planner
+       dev-ros/carrot_planner
+       dev-ros/clear_costmap_recovery
+       dev-ros/costmap_2d
+       dev-ros/dwa_local_planner
+       dev-ros/fake_localization
+       dev-ros/global_planner
+       dev-ros/map_server
+       dev-ros/move_base
+       dev-ros/move_slow_and_clear
+       dev-ros/nav_core
+       dev-ros/navfn
+       dev-ros/robot_pose_ekf
+       dev-ros/rotate_recovery
+       dev-ros/voxel_grid
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/navigation/navigation-9999.ebuild b/ros-meta/navigation/navigation-9999.ebuild
new file mode 100644 (file)
index 0000000..483b54d
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="2D navigation stack"
+LICENSE="BSD LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/amcl
+       dev-ros/base_local_planner
+       dev-ros/carrot_planner
+       dev-ros/clear_costmap_recovery
+       dev-ros/costmap_2d
+       dev-ros/dwa_local_planner
+       dev-ros/fake_localization
+       dev-ros/global_planner
+       dev-ros/map_server
+       dev-ros/move_base
+       dev-ros/move_slow_and_clear
+       dev-ros/nav_core
+       dev-ros/navfn
+       dev-ros/robot_pose_ekf
+       dev-ros/rotate_recovery
+       dev-ros/voxel_grid
+"
+DEPEND="${RDEPEND}"