projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5ce55ea
)
sci-electronics/kicad: replace the for loop with the funky while loop
author
Göktürk Yüksek
<gokturk@gentoo.org>
Sun, 22 Jan 2017 01:57:29 +0000
(20:57 -0500)
committer
Göktürk Yüksek
<gokturk@gentoo.org>
Sun, 22 Jan 2017 04:30:10 +0000
(23:30 -0500)
Package-Manager: portage-2.3.0
sci-electronics/kicad/kicad-4.0.5.ebuild
patch
|
blob
|
history
diff --git
a/sci-electronics/kicad/kicad-4.0.5.ebuild
b/sci-electronics/kicad/kicad-4.0.5.ebuild
index 2544592c299084f1f8c84dc1558c0ef4da1e3283..dfaae912cc91dfff9640dd11180990b0cef04a25 100644
(file)
--- a/
sci-electronics/kicad/kicad-4.0.5.ebuild
+++ b/
sci-electronics/kicad/kicad-4.0.5.ebuild
@@
-77,9
+77,9
@@
src_prepare() {
eapply "${FILESDIR}/${PN}-4.0.4-boost-context.patch"
# remove all the non unix file endings
-
for f in $(find "${S}" -type f -name "*.desktop")
; do
+
while IFS="" read -d $'\0' -r f
; do
edos2unix "${f}"
- done
+ done
< <(find "${S}" -type f -name "*.desktop" -print0)
# Remove cvpcb desktop file while it does nothing
rm "${WORKDIR}/${P}/resources/linux/mime/applications/cvpcb.desktop" || die