dev-lang/yasm: Use python_setup instead of python_export_best
authorMichał Górny <mgorny@gentoo.org>
Thu, 28 Nov 2019 17:27:21 +0000 (18:27 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 29 Nov 2019 08:14:30 +0000 (09:14 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-lang/yasm/yasm-1.2.0-r1.ebuild
dev-lang/yasm/yasm-1.3.0.ebuild
dev-lang/yasm/yasm-9999.ebuild

index be32d57759d7abc689d805b44207808af8cf8a4c..9cd5c98942fbfc3ae40f3222082162017a61edd9 100644 (file)
@@ -37,7 +37,7 @@ src_prepare() {
 }
 
 src_configure() {
-       use python && python_export_best
+       use python && python_setup
 
        econf \
                $(use_enable python) \
index cee1a7f6f93e864f28a1ae1ec5e58f893ffdf433..e1ef59791ee033412d57c303a8bee4a1f98f0da8 100644 (file)
@@ -26,7 +26,7 @@ DEPEND="
        python? ( >=dev-python/cython-0.14[${PYTHON_USEDEP}] )"
 
 src_configure() {
-       use python && python_export_best
+       use python && python_setup
 
        XMLTO=: \
        econf \
index c667fd21f2b29d1f5b7470029383878075711408..1dc81bc993d4d093904fcd7262bfe65e5e4a9515 100644 (file)
@@ -50,9 +50,9 @@ src_prepare() {
 
 src_configure() {
        if [[ ${PV} == 9999* ]]; then
-               python_export_best
+               python_setup
        else
-               use python && python_export_best
+               use python && python_setup
        fi
 
        econf \