projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
80cd584
)
app-admin/kube-bench: Fix build with go-1.12
author
Manuel Rüger
<mrueg@gentoo.org>
Mon, 28 Oct 2019 13:56:59 +0000
(14:56 +0100)
committer
Manuel Rüger
<mrueg@gentoo.org>
Mon, 28 Oct 2019 13:57:26 +0000
(14:57 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
app-admin/kube-bench/kube-bench-0.0.34.ebuild
patch
|
blob
|
history
diff --git
a/app-admin/kube-bench/kube-bench-0.0.34.ebuild
b/app-admin/kube-bench/kube-bench-0.0.34.ebuild
index cf7b9e1eb7265af88456a39dbb772fcb873c9a3e..5b943f248d2ef076f48f3bac3da090c31c05a91e 100644
(file)
--- a/
app-admin/kube-bench/kube-bench-0.0.34.ebuild
+++ b/
app-admin/kube-bench/kube-bench-0.0.34.ebuild
@@
-49,7
+49,7
@@
RESTRICT="test"
src_compile() {
pushd src/${EGO_PN} || die
- GOPATH="${S}" go build -mod vendor -v -ldflags "-X github.com/aquasecurity/kube-bench/cmd.KubeBenchVersion=${PV}" -o ${PN} . || die
+ GO
111MODULE=on GO
PATH="${S}" go build -mod vendor -v -ldflags "-X github.com/aquasecurity/kube-bench/cmd.KubeBenchVersion=${PV}" -o ${PN} . || die
popd || die
}